cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Creating a channel tab for planner

I currently have a flow that creates a planner plan via the graph API. After creating the plan, I want to create a tab in a teams channel that holds the newly created plan.

 

Here's how I'm trying to do it now:

smillerIA_0-1608216974110.png

The flow will succeed and adds a tab to the correct channel. However, this tab doesn't load anything. After I see the loading spinner for 30-60 seconds, I'm shown this error:

smillerIA_1-1608217060504.png

 

If I click on the globe icon in the top right corner, while on the planner tab, it takes me to the correct plan in my browser, so I know that I'm getting the URL and Plan ID correct.

 

I've also tried changing the body of the HTTP to use the parameters for a general "web" tab, rather than the special type of planner tab, but this doesn't work either.

 

Any ideas on why the planner tab won't work? Is this a known issue, or am I missing something in my API call.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

@Expiscornovus  My version shows the new, re-branded Tasks by Planner and To Do.

 

I've solved this through a solution that I found in a blog from someone who was building this with custom code (not in power automate).

 

The solution was to change the contenturl to this 

smillerIA_1-1608757313672.png

 

I'm not sure where that URL comes from. It is not documented by Microsoft, but it works. Upon opening the planner tab, it does flicker and try to load a bit before it works.

View solution in original post

6 REPLIES 6
Expiscornovus
Super User
Super User

Hi @Anonymous,

 

I can reproduce this behaviour, so it might be a bug.

 

I just noticed that Microsoft is rebranding/changing the installed app to Tasks by Planner and To Do.

 

tasksbyplannerandtodo.png

 

Which version do you have in your tenant?

 

planner_111.png

Anonymous
Not applicable

@Expiscornovus  My version shows the new, re-branded Tasks by Planner and To Do.

 

I've solved this through a solution that I found in a blog from someone who was building this with custom code (not in power automate).

 

The solution was to change the contenturl to this 

smillerIA_1-1608757313672.png

 

I'm not sure where that URL comes from. It is not documented by Microsoft, but it works. Upon opening the planner tab, it does flicker and try to load a bit before it works.

Expiscornovus
Super User
Super User

@Anonymous, thanks for sharing that solution. Good to know it works with a different contentUrl value 🙂

jackfreud
Frequent Visitor

I'm working on a flow too that creates a team, creates a planner and assigns it to the team, then adds a tab and assigns the planner to that tab.

 

In creating the Planner, it works sometimes and other times fails saying "

 "message""You do not have the required permissions to access this item, or the item may not exist.","
But it's doing this in a loop and the others succeed, and resubmitting the flow (after deleting the team) works too. It seems like a synchronicity problem: maybe it's trying to create the Plan and assign it to the team before the team exists enough to be available? 

I need this flow to be robust and wonder if anyone else has experienced this, and how to handle issues like this?
 

jackfreud_0-1639516331433.png

Also, I'm having the issue that the original poster had as well: the plan is created and it's associated with the Team/channel, but the tab shows up as blank, until I go to Settings and associate the tab to an existing plan (the one I'd created). At that point, the plans I also created for other channels in this Team also show up after a flicker or two. 

 

Any help would be enormously appreciated!

If your Flow creates the Team and then immediately creates a Planner in the same 365 Group your problem is likely that the Group and Team and not fully set up when the Planner creation is attempted. Just put a 1 minute delay in between the Team creation and the Planner creation and you won't see this issue anymore.

Thanks, I'm trying that plus setting the retry parameters for the action itself. Hopefully that will keep this from reoccuring.

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (1,843)