cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Supercue
Regular Visitor

Creating a lookup column on a SharePoint list using an HTTP Request call, doesn't work

Hi, new to these forums, so I hope I've posted this correctly?

I'm trying to create a lookup column on a SharePoint list from Power Automate, using the rest call api.  I've been searching for info & examples for 2 days now and eventually managed to get a lookup column to be created, but it seems to have been created with an error and doesn't work.

This is my HTTP request call:

HTTP Request.jpg

It successfully runs and creates a lookup column on the correct list, which at first glance appears to be OK.  But when you try and edit a row on the list and set something in the newly created lookup field, there's a problem.  You can't! 😕

 

If you click on the 3 dots and click "edit item", the new fields appears without it's dropdown:

Edit Field 1.jpg

And if you click on "edit this list" to get the grid view, it looks like this:

Edit Field 2.jpg

 

However, if you go and edit the field definition, but don't change anything, and click save - it works!!

 

Sorry if this is a bit long winded, or even missing anything, but I'm about ready to pull my hair out and throw the computer out of the window.

Please help me

Steve

0 REPLIES 0

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (55,842)