cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Creating a lookup column on a SharePoint list using an HTTP Request call, doesn't work

Hi, new to these forums, so I hope I've posted this correctly?

I'm trying to create a lookup column on a SharePoint list from Power Automate, using the rest call api.  I've been searching for info & examples for 2 days now and eventually managed to get a lookup column to be created, but it seems to have been created with an error and doesn't work.

This is my HTTP request call:

HTTP Request.jpg

It successfully runs and creates a lookup column on the correct list, which at first glance appears to be OK.  But when you try and edit a row on the list and set something in the newly created lookup field, there's a problem.  You can't! 😕

 

If you click on the 3 dots and click "edit item", the new fields appears without it's dropdown:

Edit Field 1.jpg

And if you click on "edit this list" to get the grid view, it looks like this:

Edit Field 2.jpg

 

However, if you go and edit the field definition, but don't change anything, and click save - it works!!

 

Sorry if this is a bit long winded, or even missing anything, but I'm about ready to pull my hair out and throw the computer out of the window.

Please help me

Steve

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (6,252)