cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wit4r7
Regular Visitor

Creating a new Plan with MS Graph - Write requests (excluding DELETE) must contain the Content-Type header declaration.

Hey,


I'm building a flow for creating a new Planner for a group with the Microsoft Graph API.

For the request I use the Microsoft Docs https://docs.microsoft.com/en-us/graph/api/planner-post-plans?view=graph-rest-1.0&tabs=http

 

Recieving a plan works fine, but I can't create a new one. I get the error Write requests (excluding DELETE) must contain the Content-Type header declaration.

 

The Content Type is in the request. Please see the Screenshots

https://www.directupload.net/file/d/5803/mzw8loaf_png.htm

https://www.directupload.net/file/d/5803/nvqiloje_png.htm

https://www.directupload.net/file/d/5803/fgak2av6_png.htm

 

Has anyone an idea whats wrong?

 

Thanks to all 🙂

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi @wit4r7 

 

You have to pass the authorization as header in the headers section and pass JSON in the body (for items that you are passing in the query parameter)

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

wit4r7
Regular Visitor

I found my mistake.
I put the body into the Queries and not into the body field. Then everything worked fine for me.

 

Passing the authentifaction as raw workes fine as well, it is not nessesarry to put into the header.

 

Best regards

wit4r7

View solution in original post

3 REPLIES 3

Hi @wit4r7 

 

You have to pass the authorization as header in the headers section and pass JSON in the body (for items that you are passing in the query parameter)

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

wit4r7
Regular Visitor

I found my mistake.
I put the body into the Queries and not into the body field. Then everything worked fine for me.

 

Passing the authentifaction as raw workes fine as well, it is not nessesarry to put into the header.

 

Best regards

wit4r7

Hi 

 

Could you probably share information how you did that with screenshots? That would be very helpfull. thanks.

 

BR 

Tnb

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events happening this month - don't miss out!

 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (4,412)