cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate IV
Advocate IV

Creating a note in Common Data Service (CDS) within a solution

Hi

 

I am trying to create a note record with an attachment in CDS. Document attribute in CDS connector accepts base64 encoded string. 

 

When I create a Flow from CDS solution and save it, I get the following problem with base64 expression.

I did the same thing outside of the solution without any issue.

 

How do I solve this issue?

 

Screenshot 2019-11-03 at 7.27.26 AM.png

Flow error when it is created via CDS solution

 

FYI

When I looked the code view, they are different, especially parameters and method. I noticed curly brackets { } are missing at document body in a Flow created inside CDS solution.

 

Screenshot 2019-11-03 at 7.30.09 AM.png

Code from Flow created in the solution

 

 

Screenshot 2019-11-03 at 7.30.17 AM.png

Code from Flow created outside of the solution

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Creating a note in Common Data Service (CDS) within a solution

Hi @cakhaing ,

 

Could you please explain more details about the Code from Flow created in the solution and Code from Flow created outside of the solution that you mentioned?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Advocate IV
Advocate IV

Re: Creating a note in Common Data Service (CDS) within a solution

I created a Flow in CDS solution. Screenshot 1 is the trigger and an action of the Flow. An action is to create a note in CDS, and it uses base64 expression. When I save the Flow, it shows me an error.

 

I re-created a Flow outside of CDS solution, and this has the same trigger and the same action. I can save the Flow.

 

Screenshot of peek code are from those Flows to highlight the differences.

Highlighted
Advocate II
Advocate II

Re: Creating a note in Common Data Service (CDS) within a solution

Hey,

 

  I just tried the same, and I can reproduce the error. Can't explain the difference, but, it seems, it's just expecting a prefix to know what that base 64 represents. For example, if you use the following expression, it seems to work:

 

concat('data:image/png;base64,',base64('12'))

 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (8,413)