cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Sky
Level: Powered On

Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hello everybody,

 

I'm trying to make a flow to create a new issue on JIRA, so I have set the informations about the connection between JIRA and MS FLOW, that show me informations entred were good: I can see the green circle:Capture_Status_Connexion.PNG

 

 

 

 

But when I try to execute my flow I get an InternalServerError (error 500) and my issue isn't created in JIRA.Capture_Failure_Execution.PNG

 

Capture_Error_500.PNG

 

 

 

 

I was thinking that was due to some permissions or something like that but I don't think so because when i'm editing my flow I can see all Project and Issue Type, so JIRA and MS FLOW are well connected.

Capture_Create_New_Issue.PNG

 

 

 

 

Did someone can help me ?

 

Thank's a lot.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Sky
Level: Powered On

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hello again,

 

I finally found what the problem was ! There's a request blocker in my company network.

So when we try to request the JIRA url, the request is blocked with the following message:

Capture_ERROR_JIRA_Reworked.png

To be able to see that, I was forced to create a personalized connector for JIRA.

 

Thank you.

Robin. 

 

 

7 REPLIES 7
Community Support Team
Community Support Team

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hi @ Sky,

 

Could you please share a full screenshot of the configuration of your flow?

 

I have made a test on my side and don't have the issue that you mentioned, the screenshot of my flow as below:

Capture.PNG

 

The flow would run successfully as below:

Capture.PNG

 

As is said in the troubleshot flow link:

https://docs.microsoft.com/en-us/flow/fix-flow-failures#authentication-failures

The error 500 maybe a temporary or transient failure,

Please click or tap Resubmit to try the flow again to see if the issue still exists.

 

 

 

 

 

Regards,
Alice Zhang

Sky
Level: Powered On

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hi,  @v-yuazh-msft ,

 

Thank you for answering so fast. Sadly, the 500 error isn't temporary. I've tried the Resubmit and no effects. I've also tried to execute a flow model(models ready to use) contraining JIRA and I've got exactly the same problem. Here are full screenshot of my flow:

Capture_full_flow.PNG

 Capture_First_Error.PNG

 Capture_Second_Error.PNG

 

 

 

 

So maybe it's an authorization problem on JIRA. Also to make my flows work with the 'For a selected item' sharepoint element, I was contraint to enable cookies for flow.microsoft.com because my system settings don't enable cookie(because it's a company computer) . Of course I've enabled cookies for JIRA too . I'm pretty sure my problem here is something dark like that

Here's a screenshot of the authorization I've been contraint to add on Google Chrome:

Capture_autorisation_ms.PNG

 

 

 

Sky
Level: Powered On

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hello,

 

I still can't make the JIRA connector work. So I've tried on the JIRA instance to make a call to the API (try the url https://mycompanyurl.com/jira/rest/api/2/project) and that send show me well all projects to json format.

Capture_AAA_JIRA_API_CALL_Reworked.png

As we can see on the screenshot I have a result if I make the call to the API from my browser. But not when I try from MS flow. 

 

 

 

So I have tried to put this url into my MS Flow JIRA connector:

Capture_AAA_JIRA_Reworked.png

 

 

But I'm still having this 500 Internal error for "unexpected character '<' ". It seems like I get an HTML response instead of a JSON response. Or something went wrong on JIRA side so it send an HTML response.

 

I have also tried to put my url like :

-https://mycompanyurl.com/jira

-https://mycompanyurl.com/jira/

-https://mycompanyurl.com/jira/rest/api/2/

 

But this is still not working and I still get the same error each time.

Can someone tell because of what it's due ? Have we to set permissions on JIRA side to make the connector work ?

Have we to configure a response format on JIRA side ? Or have to set something else on MS Flow side ?

 

Thank's a lot.

Robin.

Sky
Level: Powered On

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hello again,

 

I'm really sad to see that nobody is able to help me Smiley Sad

 

I've tested to set exactly the same connexion to JIRA in another system like MS Flow but from another company and it work perfectly. (Same base_url, same user, same password) I can create, list and update issues.

So I don't understand why it's not working with MS Flow and that make me say the problem is on MS Flow side.

 

Can my problem be due to the fact my permium licence of MS Flow was trial version for 15 days ?

 

Is there any documentation about the JIRA connector with more informations about error than the classic one ?

 

Thank you.

Robin

Sky
Level: Powered On

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hello again,

 

I finally found what the problem was ! There's a request blocker in my company network.

So when we try to request the JIRA url, the request is blocked with the following message:

Capture_ERROR_JIRA_Reworked.png

To be able to see that, I was forced to create a personalized connector for JIRA.

 

Thank you.

Robin. 

 

 

Sru
Level 8

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

hi @Sky

Can you please tell me how to establish a jira conenction. I tried giving url and login details but it gives me " Network request failed " eception.

 

Do we need to have admin access to jira for connection to establish? Could you help

 

Thanks,
Sru

Harry_G
Level 8

Re: Creating flow to connect sharepoint to JIRA but having errors when creating a new issue

Hi @Sky ,

I'm facing same problem for JIRA connection, can you please tell me that how can you resolve it.

 

Thanks,

Harry_G  

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 386 members 5,785 guests
Please welcome our newest community members: