cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

D365CE: Display label from lookup-field in HTML composed mail

Hi community,

 

I'm currently working on a flow, with the following steps that work already:

  • Get record (Preview) for a dedicated entity in CRM
  • odata filter for the last 14 days
  • create an array for the result set
  • check if there is at least one record within the result set
  • Compose a HTML table with dynamics values (including the value of a lookup field) and others
  • Append this to the array
  • compose a final HTML table with the join-expression inside the body
  • Sending the result as email (V3 preview) to several receipents

All this works fine. The only thing is, that the column for the lookup-field inside the sent email is blank.

I am able to display the GUID and the type....only the label does not work.

 

I hope somebody can understand my problem. If you need more details please ask.

 

Thanks a lot in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

Thanks for the screenshot.

 

Inside the loop before Create Row add Get Record flow step. Pass the _xrm1_data_change_employee_id_value. Next step you should be able to map the name. See below

 

get1.png


If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

View solution in original post

12 REPLIES 12
Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

You mentioned that the column for the lookup-field inside the sent email is blank. Which column you are referring to? Could you post your flow screenshot?

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm 

 

here are more details:

The flow runs for the custom entity "Data Change". This entity has a lookup to another custom entity "Employee".

I am referring to this lookup inside the flow to display the employees name in the final composed mail.

 

I cannot upload images...only insert by URL is possible 😞

An idea how to handle this?

 

Cheers

Sven

Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

Are you trying to get the Employee details instead of GUID? Also you mentioned cannot upload images which you didn't mentioned in your first post. I am a little bit lost here. Could you please explain?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm,

 

I just mean I can't post images inside here. The editor has no option for that...

How do you post screenshots in here?

 

I don't want to get details from the employee record. I just want to get the primary key name of it as it gets displayed in lookup fields on D365CE forms.

 

Cheers

Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi,

 

If you want to get the primary key name from the lookup then you need to pass the GUID and use the get record step. Be default the lookup mapping will give you only the GUID. If you using SDK via C# custom code you should be able to access the GUID and display name. From flow you won't be able to do this.

 

If you want to upload a screenshot click the photos options from the editor top menu for uploading images.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm,

 

now the upload images feature is working.

Here is my setting:

01.png02.png03.png04.png

 

Cheers

Sven

Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

Sorry English is my primary language. Could you please let me know which step and which mapping you referring to?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm,

 

here more in detail:

This is step "Dynamics get Record", where I receive all records from this entity based upon the filter 

addDays(utcnow('yyyy-MM-ddTHH:mm:ssZ'),-14)

 

 

01.png

 

I use these result set in the "true-branch" with a "compile-step" to create the HTML-table.

02.png

First highlighted is the custom entity, I reffer to. Second one is the lookup called "Mitarbeiter", which is not displayed. All4 other values are displayed correctly but these are not lookups - they are all text fields.

 

Next I attach the compiled content output into the array:

03.png

Then I build the final HTML-table and insert the array:

04.png

This is the join expression: 

join(variables('Datensatzliste'),'')

 

 

Thats all. The final table in the email looks like this:

05.png

In here are all fields displayed except the first column. It stays empty with this setting.

 

Hope you get the problem now.

 

Thanks!

Sven

Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

Thanks for your reply and explanation.

 

Couple of things you could check.

 

1. From the run history check the 'Mitarbeiter' values whether it's null or not.

2. If you looking to get the 'Mitarbeiter' name (believe this is a lookup) then you need to use another Get Record pass this GUID and get the name. Map the name in your mapping step.

 

If you need any further help please let me know.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm,

 

good hint with the run history. I checked it and get the following message:

{
      "@odata.etag": "",
      "ItemInternalId": "db50b45f-9d7d-4e1d-8ada-99cbde08be10",
      "_owningbusinessunit_value": "fd22aeef-98ce-e811-a952-000d3a44a96b",
      "_owningbusinessunit_type": "businessunits",
      "xrm1_name": "\"Bundesland/Gebiet (Arbeit)\" wurde von \"\" zu \"Baden-Württemberg\" geändert.   ",
      "xrm1_new_value": "Baden-Württemberg",
      "statecode": 0,
      "_statecode_label": "Aktiv",
      "_xrm1_data_change_employee_id_value": "6a45a529-0677-e911-a961-000d3a3a3fc8",
      "_xrm1_data_change_employee_id_type": "xrm1_employees",
      "_createdby_value": "021b7990-e813-4c0d-99b9-18435766cc93",
      "_createdby_type": "systemusers",
      "timezoneruleversionnumber": 0,
      "_ownerid_value": "ccaf150a-6bdb-e811-a954-000d3a464709",
      "_ownerid_type": "systemusers",
      "modifiedon": "2019-09-11T07:10:04Z",
      "_modifiedby_value": "94bc916e-76db-e811-a957-000d3a464f85",
      "_modifiedby_type": "systemusers",
      "xrm1_field_name": "Bundesland/Gebiet (Arbeit)",
      "versionnumber": 14585838,
      "createdon": "2019-09-11T07:09:55Z",
      "xrm1_data_changeid": "db50b45f-9d7d-4e1d-8ada-99cbde08be10",
      "statuscode": 1,
      "_statuscode_label": "Aktiv",
      "xrm1_change_date": "2019-09-11",
      "xrm1_former_value": null,
      "_createdonbehalfby_value": null,
      "_owningteam_value": null,
      "_modifiedonbehalfby_value": null,
      "importsequencenumber": null,
      "overriddencreatedon": null,
      "utcconversiontimezonecode": null
    }

Marked in red I can see, that only the GUID and type are retreived.

 

So your suggestion is to establish another step to get the label for this record, right?

Am I right putting it in here?

01.png

 

Thanks

Sven

Highlighted
Super User III
Super User III

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @Sven_Burkhardt 

 

Thanks for the screenshot.

 

Inside the loop before Create Row add Get Record flow step. Pass the _xrm1_data_change_employee_id_value. Next step you should be able to map the name. See below

 

get1.png


If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

View solution in original post

Highlighted
Frequent Visitor

Re: D365CE: Display label from lookup-field in HTML composed mail

Hi @abm,

 

that's it! Now I get the names of the employees displayed.

 

Thanks a lot for your help! I really appreciate it ^^

 

Cheers

Sven

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (7,063)