cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Prodigy
Post Prodigy

DCRM Update record returns status 400

Hello,

I've created a flow to update a record whenever a case is created in the Cases entity.

Unfortunately, the flows keep failing on the update record action with status code 400, knowing that I am using the current environment connection and the same user that I am currently signed in. Also the record identifier from the first action which is "When a record is created".
Besides, I've also switched my triggers to CDS connectors and nothing has been changed and the flow fails again.

Here is a screenshot about my flow:

Error.PNGFlow.PNG
What could be the issue?

Any help will be greatly appreciated.

Thank you!

12 REPLIES 12
Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hi @Julien2 

 

Any particular reason why you are using the CDS connector for a couple actions and the dynamics for the other ones? Because after the get record action, when you have the condition, you are bascially referring to the trigger action only and it will not fetch the values appropriately. My first recommendation would be to keep consistency in the connectors that you are using in the flow. Canyou share the screenshot of the entire update record action? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hi @yashag2255 

 

I've switched to Dynamics connectors for all actions, and the flow keeps failing.
Here is a screenshot of my flow, and the latest error with the modified connectors:

Flow1.PNGFlow2.PNG

In the update record action, I just want to update the Owner field. Also, I've tried to update some other fields but also i get a bad request.

 

Looking to hear from you.

Thanks.

Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hi @Julien2 

 

So for the update to work, you need to update/ provide data for all the required fields on the entity. Here is what you can do: after the trigger add an action get record from dynamics and select the appropriate entity/ organization and then in the identifier pass it from the trigger outputs. 

 

Now in the update record action, refer to all the fields (required ones) from the get record actions outputs. SO can you try with this and check if you are facing the same issue? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hi @yashag2255 

I have also given a try with updating all the fields from the get record actions and I've checked for all the required fields in the Cases entity and mapped them into the update record action.

Unfortunately, I am still facing the same issue but with another error that says "Invalid lookup_type value".Also, For the Owner field, I am using the following expression.
first(body('List_records')?['value'])?['systemuserid']

 

Please take a look at the results below:

Capture.PNGCapture1.PNG

What I should change to fix this error?

Thank you for your support.

Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hi @Julien2 

 

That string should be as an expression. So in the owner field, place the cursor and shift to the expression editor. Paste that expression over there and click okay. It should come as an expression in the action. 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hi @yashag2255,

That's right, I've added the expression into the editor and it returns the right owner filtered.

But I still receive Invalid Lookup type value error no idea why, and the problem it doesn't show on which field.

 

Capture.PNG

Which column might return the following issue?

Thank you.

Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hey @Julien2 

 

I see. There must be some other look up vale as well. Can you check on the entity and confirm about the same? In the owner type field, please select the option as user and try again. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hi @yashag2255,

 

I have checked again for all the lookup required values and mapped them into the fields, besides, I have select users for the owner type.
Unfortunately, now I am receiving the first error that occurred before which is the batch response status 403.

Here is a screenshot:

Capture.PNG

Thank you.

 

Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hi @Julien2 

 

So now the users part is sorted, I would recommend removing everything from the update record action and start adding stuff one by one to check where it might be failing. 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hi @yashag2255,

 

I have created the same flow in Solutions and switched the connectors too (CDS Current Environment), after that the update record action works only when I remove the Owner expression that I have recently use it in the Owner field (Mainly, now the problem occurs from the expression).

Besides, how I can get the label of the specific field because using the CDS connector I was not able to find in the dynamic content the Labels for fields for e.g. Country field I can't find Country Label.

Capture3.PNG

 

Here is the flow error:

Capture2.PNGCapture.PNG

What could be the issue now?

 

Looking to hear from you.

Thank you.

Highlighted
Dual Super User
Dual Super User

Re: DCRM Update record returns status 400

Hi @Julien2 

 

Were you able to resolve this? 

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: DCRM Update record returns status 400

Hello @yashag2255,
Thanks for asking.
Unfortunately, I couldn't fix this issue and the flow keeps failing with a message  "Resource not found for this segment".

Besides, I have tried to use the same filter query in the Owners entity, to get from this query the owner name and map the expression in the update record action for the owner field the flow says that "Owners entity not found".(I was wondering why it's not found since it already exists in the dropdown where I select the entities). I have tried to search for this entity in Customaziations-> Customize the system, but I couldn't find it.

 

Finally, if I can solve the Owners entity so I can filter my query to get the GUID of the user and use my query in the update record action.

 

Do you have any idea about the Owners entity?

 

Thank you!

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (6,277)