cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
DaleJohnny
Helper I
Helper I

Dataverse Dataflow failed without error

Hi all,

 

Until yesterday all my new Dataflows failed. Normally i can download the error-log. But for the new failed dataflows the error log is empty. 

 

E.g.

DaleJohnny_0-1615361548276.png

This Dataflow runs this morning and throw an error.

If i want to see more details in "show refresh history", the log is empty.

DaleJohnny_1-1615361584303.png

Does anyone know this error and the solution?

 

BR

Dale

 

4 REPLIES 4
DaleJohnny
Helper I
Helper I

Hi all,

 

Now i receive this error.....

DaleJohnny_0-1615445887681.png

 

section Section1;
shared revenue = let
  Quelle = Sql.Database("SERVERNAME / DATABASE"),
  Navigation = Quelle{[Schema = "dbo", Item = "revenue"]}[Data],
  #"Geänderter Spaltentyp" = Table.TransformColumnTypes(Navigation, {{"lastinvoicedate", type text}}),
  #"Spalte nach Trennzeichen teilen" = Table.SplitColumn(#"Geänderter Spaltentyp", "lastinvoicedate", Splitter.SplitTextByDelimiter("-"), {"lastinvoicedate.1", "lastinvoicedate.2", "lastinvoicedate.3"}),
  #"Neu angeordnete Spalten" = Table.ReorderColumns(#"Spalte nach Trennzeichen teilen", {"Debitor", "revenue", "currentyearrevenue", "previousyearrevenue", "revenueyear", "revenuedbtotal", "currentyeardb", "previousyeardb", "revenuedbpercent", "revenue_dell", "revenue_hp", "revenue_lenovo", "ordersyear", "lastinvoicedate.2", "lastinvoicedate.3", "lastinvoicedate.1"}),
  #"Zusammengeführte Spalten" = Table.CombineColumns(#"Neu angeordnete Spalten", {"lastinvoicedate.2", "lastinvoicedate.3", "lastinvoicedate.1"}, Combiner.CombineTextByDelimiter("/", QuoteStyle.None), "lastinvoicedate")
in
  #"Zusammengeführte Spalten";

 

 

I'am sysadmin in cds and the sql - also are all credentials right.

FCGALLEG
Community Support
Community Support

Hi DaleJohnny,

We don't have enought info to see where the issue is.

Please, open a ticket with support in order we can analyze everything.

 

Also, It seems a problem in the connection with the SQL, have you check the connection? did you take network trace to see if you have an error?

 

Thanks,

Javier

 

Hi @FCGALLEG 

 

We already open a ticket but no answer yet.

 

The great thing is, on our dev the same dataflow works without problems. Also I can create new dataflows there and they work. Therefore, it can not be due to the settings.

DaleJohnny
Helper I
Helper I

Does anyone have a solution?

 

The support doenst answer to my ticket yet...

 

Thanks forward

BR

Dale

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,360)