cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
swolfsohn
Level: Powered On

Definition contains invalid parameters - previously working flow won't save even with no edits

Hello - 

 

I have a large flow that has been running successfully for weeks (and is still running successfully). Now I want to make a minor change, but when I try to save I get a generic error at the top of the flow editor which just says "Definition contains invalid parameters".

 

I did not list the details of the change I'm trying to make because this error comes up even if I don't make any changes at all (despite the fact that the flow is successfully running almost daily).

 

If I just open the flow for editing and hit save, I don't get an error, but as soon as I click inside any field in the Create Item action (even if I don't actually type or make any changes), hitting save gives the "Definition contains invalid parameters" error. I don't see any detailed error on any field or action anywhere in the flow. 

 

I tried making a new "Create Item" and completely deleting the old one, but still got the same error.

 

Is there any way to get more detailed information on this issue so I can actually troubleshoot it?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Definition contains invalid parameters - previously working flow won't save even with no edits

Hi @swolfsohn,

 

Could you please share a screenshot of the configuration of your flow?

Could you please share more details about the error message?

 

The "Definition contains invalid parameters" error means your flow contain invalid parameters, please check your flow for all actions or please take a try recreate the flow to see if the issue still exists.

 

Best regards,

Alice

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Definition contains invalid parameters - previously working flow won't save even with no edits

Hi @swolfsohn,

 

Could you please share a screenshot of the configuration of your flow?

Could you please share more details about the error message?

 

The "Definition contains invalid parameters" error means your flow contain invalid parameters, please check your flow for all actions or please take a try recreate the flow to see if the issue still exists.

 

Best regards,

Alice

View solution in original post

Administrator
Administrator

Re: Definition contains invalid parameters - previously working flow won't save even with no edits

Hey, @swolfsohn!

 

Thank you for posting on the Flow Community Forum! It appears as though @v-yuazh-msft would like some more information in order to further assist you properly with your issue. Please share any additional information that was requested in order to decrease the amount of time that it will take for you to be assisted!

 

Thank you for being an active member of the Flow Community!

 

-Gabriel
Flow Community Manager

-Gabriel
Microsoft Power Automate Community Manager
Are YOU a member of your local Power Automate User Group?
Fill out This Form to claim your Community User Group Member Badge!
swolfsohn
Level: Powered On

Re: Definition contains invalid parameters - previously working flow won't save even with no edits

I apologize for the delay, I haven't had a chance to try rebuilding my flow because it is quite long. I put screenshots of the full configuration below. I didn't expand the create/edit item actions because there are quite a few fields and it would take too many screenshots. I have checked every individual action for more specific errors but I do not see any info anywhere other than what is shown at the top of the first screenshot. That appears when I try to save even when I don't change anything. This flow is still actively running and working successfully multiple times a day, it just won't let me make and save any changes. Note that while I haven't rebuilt the entire flow, I did try to rebuild and replace the specific block I would like to change and it did not solve the problem. It doesn't seem to matter which action I click inside of - the flow fails to save once I have clicked in any field in any action. Is there any way for me to further troubleshoot this on my own and determine what about my definition is invalid other than posting more screenshots? Are there specific blocks I should try rebuilding even if I don't see an error?

 

I very much appreciate any efforts to help me with this.

 

Screenshot1.pngScreenshot2.pngScreenshot3.pngScreenshot4.pngScreenshot5.pngScreenshot6.pngScreenshot7.pngScreenshot8.png

dhock
Level: Powered On

Re: Definition contains invalid parameters - previously working flow won't save even with no edits

That's your solution? The error message needs to be more detailed. The Flow saved fine the first time around, and there is no other indication anywhere else in the Flow of what the problem might be. I've got the same issue.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 234 members 5,062 guests
Please welcome our newest community members: