cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sumeetrajan
Helper I
Helper I

Delay notification

Hi,

 

I am trying to do the following

1. email notification when a new item is created in SharePoint - No issue.

2. email notification after 8 hours to update the SharePoint list - facing issue. 

 

Logic i  am using 

1. use created time in SharePoint & converting into the required timezone

2. adding 8 hours via "Add to time"

3. using delay until connector.

4. sending mail

 

getting following error

"The 'timestamp' value of the 'Wait' action 'until' inputs must be specified in UTC using the round-trip date/time pattern (for example, '2015-10-22T10:00:00Z'). For details please review the Standard Date and Time Format Strings of the .Net framework." 

 

any solution?

 

sumeetrajan_0-1619594093647.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
fchopo
Super User II
Super User II

Hi @sumeetrajan 

Please, be sure that you use ISO 8601 format in the Delay until expression:

formatDateTime(body('add_to_time'),'yyyy-MM-ddThh:mm:ssZ')

Hope it helps!

Ferran

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

View solution in original post

4 REPLIES 4
fchopo
Super User II
Super User II

Hi @sumeetrajan 

Please, be sure that you use ISO 8601 format in the Delay until expression:

formatDateTime(body('add_to_time'),'yyyy-MM-ddThh:mm:ssZ')

Hope it helps!

Ferran

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

View solution in original post

sumeetrajan
Helper I
Helper I

Hi,

 

I was able to remove the error but then we don't have any delay!

fchopo
Super User II
Super User II

Could you show the expressions you have inside each step in the flow?

Regards,

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
sumeetrajan
Helper I
Helper I

Hi,

 

i was able to solve it, I used "delay" function instead of "delay until". thanks 🙂

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (26,971)