cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Delete on metadata change

Hi!

 

I have a sharepoint document library called "All Documents", in this library I have a metadata field that is names "Customer".

Then I have another document library in the same site that is called "Customers" and in this library I have folders with my customers names.

When I tag a document in the "All Documents" library with one or more customer I have a flow that copy the tagged document to the customers folders that is in the tag in my "Customers" library.

This works good, but I would also like to have a delete flow.

I can not get the delete flow to work, I guess I am missing something essential, I am pretty new to flow.
Delete flowDelete flowCan not find the fileCan not find the file
If I put the site address and the file identifier in my browser the pdf opens, so the url is correct.
What am I missing?
Thanks in advance!

2 ACCEPTED SOLUTIONS

Accepted Solutions
Super User III
Super User III

Hi @Tuxarn 

 

I have replicated your error. What you need to do is under the file identifier replace all the '/' with '%2F'

 

Something like below:


%2FCustomers%2FCustomer Value%2FFile name with extension

 

For dynamic mapping you can't use slash you need to use %2F (Magic). If you browse and set the path you can use the slash.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

View solution in original post

Community Support
Community Support

Hi @Tuxarn ,

 

Do you what to delete the special file in the "Customers" library when a file in "All Documents" should be deleted?

 

If yes, you should refer to screenshot below to create the flow:

1.png

 

 

Best Regards,

Alice

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Super User III
Super User III

Hi @Tuxarn 

 

I have replicated your error. What you need to do is under the file identifier replace all the '/' with '%2F'

 

Something like below:


%2FCustomers%2FCustomer Value%2FFile name with extension

 

For dynamic mapping you can't use slash you need to use %2F (Magic). If you browse and set the path you can use the slash.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials

View solution in original post

Community Support
Community Support

Hi @Tuxarn ,

 

Do you what to delete the special file in the "Customers" library when a file in "All Documents" should be deleted?

 

If yes, you should refer to screenshot below to create the flow:

1.png

 

 

Best Regards,

Alice

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I understand, thanks so mutch for the quick response! will try it and give feedback.

Appreciate it @abm @v-alzhan-msft!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (8,220)