cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Jube1
Level: Power Up

DisplayName gives error "Enter a valid json."

Hi,

 

I'm trying to build automated e-mail with Flow from Sharepointlist attachments. There is instructions: https://flow.microsoft.com/en-us/blog/multiple-attachments-single-email/

 

What I'm doing wrong?

 

"Name": @{items('Apply_to_each').DisplayName}

 Gives error: Enter a valid json.

 

If I remove "Name", error disappear but flow doesn't work.

 

-Juho

2 ACCEPTED SOLUTIONS

Accepted Solutions
Community Support Team
Community Support Team

Re: DisplayName gives error "Enter a valid json."

Hi @Jube1,

 

Please add a comma "," after the "DisplayName" dynamic content if the Name is the first parameter.

or add a comma "," after the expression if the ContentBytes is the first parameter.

 

Please let me know if your problem could be solved.

 

Best regards,

Alice

View solution in original post

fermoreno
Level: Powered On

Re: DisplayName gives error "Enter a valid json."

You are just missing a comma after the first property, the last element cannot finish with comma. If you only have one as you mention (removing name and no comma) works.

 

Let me know how it goes.

 

Fer

flowcomma.png

 

 

View solution in original post

3 REPLIES 3
Community Support Team
Community Support Team

Re: DisplayName gives error "Enter a valid json."

Hi @Jube1,

 

Please add a comma "," after the "DisplayName" dynamic content if the Name is the first parameter.

or add a comma "," after the expression if the ContentBytes is the first parameter.

 

Please let me know if your problem could be solved.

 

Best regards,

Alice

View solution in original post

fermoreno
Level: Powered On

Re: DisplayName gives error "Enter a valid json."

You are just missing a comma after the first property, the last element cannot finish with comma. If you only have one as you mention (removing name and no comma) works.

 

Let me know how it goes.

 

Fer

flowcomma.png

 

 

View solution in original post

Jube1
Level: Power Up

Re: DisplayName gives error "Enter a valid json."

Brilliant! Now it works. Thanks for the help!

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 186 members 5,305 guests
Recent signins:
Please welcome our newest community members: