cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

DisplayName gives error "Enter a valid json."

Hi,

 

I'm trying to build automated e-mail with Flow from Sharepointlist attachments. There is instructions: https://flow.microsoft.com/en-us/blog/multiple-attachments-single-email/

 

What I'm doing wrong?

 

"Name": @{items('Apply_to_each').DisplayName}

 Gives error: Enter a valid json.

 

If I remove "Name", error disappear but flow doesn't work.

 

-Juho

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Community Support
Community Support

Re: DisplayName gives error "Enter a valid json."

Hi @Jube1,

 

Please add a comma "," after the "DisplayName" dynamic content if the Name is the first parameter.

or add a comma "," after the expression if the ContentBytes is the first parameter.

 

Please let me know if your problem could be solved.

 

Best regards,

Alice

View solution in original post

Highlighted
Frequent Visitor

Re: DisplayName gives error "Enter a valid json."

You are just missing a comma after the first property, the last element cannot finish with comma. If you only have one as you mention (removing name and no comma) works.

 

Let me know how it goes.

 

Fer

flowcomma.png

 

 

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: DisplayName gives error "Enter a valid json."

Hi @Jube1,

 

Please add a comma "," after the "DisplayName" dynamic content if the Name is the first parameter.

or add a comma "," after the expression if the ContentBytes is the first parameter.

 

Please let me know if your problem could be solved.

 

Best regards,

Alice

View solution in original post

Highlighted
Frequent Visitor

Re: DisplayName gives error "Enter a valid json."

You are just missing a comma after the first property, the last element cannot finish with comma. If you only have one as you mention (removing name and no comma) works.

 

Let me know how it goes.

 

Fer

flowcomma.png

 

 

View solution in original post

Highlighted
New Member

Re: DisplayName gives error "Enter a valid json."

Brilliant! Now it works. Thanks for the help!

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (11,653)