cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Don't understand errors using Save email attachment to SharePoint library template

 

I've configured the template Save my email attachments to a SharePoint document library.  I add the site url to where my library is.  It shows my all of the libraries in the site so I know the url is correct.  I then select select the library.  However when I go to save the flow it gives me 2 errors saying that a site address is required and a folder path is required even though they are both configured.  Note that in the screenshot below I grayed out most of the site address for privacy. 

 

FlowError.jpg

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Don't understand errors using Save email attachment to SharePoint library template

Hi @mfriedenberg ,

 

To write the subject of the email to a field in the library, please add the action Update file properties after the action Create file, then select dynamic content from the previous action/trigger for corresponding field.

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Don't understand errors using Save email attachment to SharePoint library template

Hi @mfriedenberg ,

 

It seems that you input the Site address by “Enter custom value”.

 

As long as you could select the library, then I assume that the site is correct.

 

Could you then save the flow?

 

Are you able to select the site address by clicking the Drop down button of Site Address?

 

I have made a similar test by configuring the flow likes below, the issue you mentioned didn’t occur.

 

Please check the following screenshot.

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Don't understand errors using Save email attachment to SharePoint library template

It turns out that that when you start the template it creates a no condition which also needs to be configured.  I deleted the No condition and was able to save and run.

One other question:

Is it possible to write to another field in the document library where the attachments are being saved?  I want to write the subject of the email to a field in the library called subject.  How would I do that?

 

Thanks

Highlighted
Community Support
Community Support

Re: Don't understand errors using Save email attachment to SharePoint library template

Hi @mfriedenberg ,

 

To write the subject of the email to a field in the library, please add the action Update file properties after the action Create file, then select dynamic content from the previous action/trigger for corresponding field.

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (4,854)