cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ShelbyMeeks
New Member

Downloaded Attachments from Email are Broken

When following templates for automatically downloading attachments from Outlook to One Drive for Business, I seem to have trouble opening that file. Originally my issue was that the files would download as generic file types instead of PDFs which made batch printing impossible. I was able to fix that my simply adding the file type to the File Name line on the Create a File action. The files are now downloading as PDFs but they are all broken and won't open or print. (The files are originally sent in PDF format from the vendor.) 

 

The only examples I've seen so far for this particular issue have been utilizing SharePoint as well, I'm just hoping I can add a small detail or step to what I've already figured out between Outlook for Business and Office 365. 

 

powerautomate.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
v-yujincui-msft
Community Support
Community Support

Hi @ShelbyMeeks ,

 

Maybe you could try to add a Get Attachment (V2) Action, it works on my side.

 

vyujincuimsft_0-1652253281658.png

vyujincuimsft_1-1652253343964.pngvyujincuimsft_2-1652253372227.pngvyujincuimsft_3-1652253422976.png

 

 

Best Regards,

Charlie Choi

View solution in original post

2 REPLIES 2
ekarim2020
Super User
Super User

Hi @ShelbyMeeks ,

 

Please see: How to save PDF email attachments to OneDrive for Business using Power Automate 

 

Note also in your flow, if the email has more than one attachment, each attachment will be saved with exactly the same name (Subject) - over writing the previous file.  As a solution you could append the current date/time to the end of each filename once you have the flow working.

 

Hope this helps.


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

v-yujincui-msft
Community Support
Community Support

Hi @ShelbyMeeks ,

 

Maybe you could try to add a Get Attachment (V2) Action, it works on my side.

 

vyujincuimsft_0-1652253281658.png

vyujincuimsft_1-1652253343964.pngvyujincuimsft_2-1652253372227.pngvyujincuimsft_3-1652253422976.png

 

 

Best Regards,

Charlie Choi

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (3,447)