cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cbracci
Level: Power Up

Dynamic Content no longer appearing

Hello, 

I have created simple flows before that include. 

Individual submits form response. 

Form submission triggers email with dynamic content pulled from said response. 

Sent to form submitter and certain designated emails. 

 

However when I went to create a similar flow none of the fields in the form are showing up in the dyanmic content box. 

I tried using the same form that worked before, no dynamic content available. 

I then tried duplicating the flow that successfully incorporated dynamic content into but in that copy dynamic content does not appear. 

 

How do I rectify this disconnect between the forms app and the flows app? 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Dynamic Content no longer appearing

Hi cbracci,

 

I have some updates for you.

 

Please use the action “Microsoft Forms – Get response details”, after this action, add other actions, then you will get all the dynamic contents for the Form.

3.PNG

 

Please try it on your side.


Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

10 REPLIES 10
cbracci
Level: Power Up

Re: Dynamic Content no longer appearing

Images of the Issue: 

Capture.JPGCapture2.JPG

Community Support Team
Community Support Team

Re: Dynamic Content no longer appearing

Hi cbracci,

 

I can reproduce this issue on my side. When I create a new flow using the trigger “Microsoft Form-When a new response is submitted”, in the next action, I can only select “Response Id” from the dynamic content.


I have reported this issue. I will back to you once I got any updates.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: Dynamic Content no longer appearing

Hi cbracci,

 

I have some updates for you.

 

Please use the action “Microsoft Forms – Get response details”, after this action, add other actions, then you will get all the dynamic contents for the Form.

3.PNG

 

Please try it on your side.


Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

neds
Level: Powered On

Re: Dynamic Content no longer appearing

I am having a similar, but not complete problem.  I am already using the Get Response Details Action.  My issue only appears with Number Fields in the Form.  The Dynamic content for number fields was working up until 3 days ago, now, the flow fails and I can't seem to access the dynamic content from ONLY the number fields of the MSFT Form response beyond the item ID.  All other fields still work and are available in the dynamic content.  You can see this below.  The matching Sharepoint List item fields have not changed, and you can actually see that in the Flow the filed used to be available (hilighted) but no longer is. Only the response ID.  The image on the left is a text field and all Dynamic Fields are available. Image on the right is from a number field (same for all number fields) and no dynamic content is available as of 3 days ago.

 

Capture.JPGCapture2.JPG

Andy_G_UK
Level: Powered On

Re: Dynamic Content no longer appearing

Hi @ Neds,

 

Did you find a solution to the problem you described above?

 

I am too finding that on number fields it will not present me with any dynamic content, but does for all other types of fields.

 

Thanks

 

Andy

jasb81
Level 8

Re: Dynamic Content no longer appearing

Hi All,

 

Even I'm facing the same issue with number fields. Any ideas whats the fix please.

 

Thanks

jag

 

 

Andy_G_UK
Level: Powered On

Re: Dynamic Content no longer appearing

Hi @neds , did you ever find a solution to the issue above? No dynamic content when trying to insert into a value field in CRM.

 

We are trying to import invoice data into CRM using a flow, we can import everthing except financial information (value fields).

 

Thanks


Andy

Artizeng
Level: Powered On

Re: Dynamic Content no longer appearing

Hi @neds, @Andy_G_UK and @v-yamao-msft  , is there any update on this?

 

I am experiencing a very similar problem whereby a dynamic content that was working no longer appears. In truth, I had some difficult getting all of the dynamic content to appear in the first instance and I am not sure why it was removed from the field. I should be able to select the 'first name' dynamic content, similar to the other fields below e.g. surname etc.

 

Flow - dynamic content issue.JPG

 

I read advice that suggested deleting the action and inputting it again but then I loose all dynamic content. 

Automate4Dom
Level: Power Up

Re: Dynamic Content no longer appearing

Hi All,

I experienced the same issue when trying to associate dynamic content onto the body of an email. Some fields appeared and many did not. I saved the flow, turned it off and then on, but the issue didn't resolve.

Happened to search for the field in the 'Search dynamic content' textbox and the fields do appear. They could all be selected onto the body of my email. Job Done!

Am still wondering why they don't show up in the list in the first place and why do we need to search explicitly. I read another blog where there was a 'Show More' option, but this is not available anymore. Only the search works.

Hope this helps!

Dominic.

 

2019_11_27_16_42_04_Edit_your_flow_Power_Automate.png

Highlighted
JHL
Level: Powered On

Re: Dynamic Content no longer appearing

Hi everybody,

 

I too am facing the same problem of dynamic content, that I was able to collect by "Get response details" earlier will not appear on a number field that I just included in my SharePoint list.

Explicitly searching for the dynamic content in the search bar also does not do the trick. 

 

Any help on this?

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (4,268)