cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Mordikus
Level: Powered On

Dynamic content always returns empty

Hello everyone, i hope my english isn't that bad (i'm mainly using mozilla firefox but i tried it with edge too)

 

i'm trying to send an email when a sharepoint list's item is updated.

 

As i want to make an approval workflow like, i would like to send an email to the n+1 to approve the content being updated.

 

In order to do that, i would like to use the dynamic content "Created by department" which in my opinion should return the department of the user who created the list's item.

 

But the "Created by department" always returns empty (or null ?) (i got the same problem with job title)

 

I put a department (and a job title) on my user from the Sharepoint admin center -> user profiles -> Manage User profiles

 

The department show up on the user's delve profile but not the job title.

 

Did i miss something, if someone can please help me, i would just kiss you if i could 🙂

 

Thanks and have a nice day !

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Microsoft Employee

Re: Dynamic content always returns empty

Hi @Mordikus,

 

Could you provide us the flow url like this(https://ms.flow.microsoft.com/manage/environments/Default-72f988bf-86f1-41af-91ab-2d7cd011db47/flows...) for further investingation?

 

I have created a similiar flow. When an item is modified in sharepoint-> send an email, And the field I modified in the sharepoint list can be successfully put to the following email body field. So the detail of your flow would help us further investigate.

 sharepointflow.png

 

Thanks

View solution in original post

13 REPLIES 13
Microsoft Employee

Re: Dynamic content always returns empty

Hi @Mordikus,

 

Could you provide us the flow url like this(https://ms.flow.microsoft.com/manage/environments/Default-72f988bf-86f1-41af-91ab-2d7cd011db47/flows...) for further investingation?

 

I have created a similiar flow. When an item is modified in sharepoint-> send an email, And the field I modified in the sharepoint list can be successfully put to the following email body field. So the detail of your flow would help us further investigate.

 sharepointflow.png

 

Thanks

View solution in original post

Community Support Team
Community Support Team

Re: Dynamic content always returns empty

Hi Mordikus,

 

I assumed that you will want to create a flow to send approval email when an item in SharePoint list is modified. And do you want to send an approval email to the user who created the item?


If yes, you could use the Dynamic content “Created by Email” in the To field, then when an item is modified in the list, an email would be sent to the user who created the item.

2.PNG

 

If I misunderstand you, please feel free correct me.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Community Support Team
Community Support Team

Re: Dynamic content always returns empty

Hi Mordikus,

 

 

Thanks for your prompt response.


I created a similar flow with you and configured the Subject and Body field with “Created by Department” and “Modified by Department”. I can get the value both of them.


As @telu has suggested, could you please provide the flow URL likes this(https://ms.flow.microsoft.com/manage/environments/Default-72f988bf-86f1-41af-91ab-2d7cd011db47/flows...) for a further investigation?

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Mordikus
Level: Powered On

Re: Dynamic content always returns empty

Hello, (i don't know if you can see because i can't see the one from telu)

 

 

Thanks

Mordikus
Level: Powered On

Re: Dynamic content always returns empty

My microsoft flow is in french, maybe it can explain ...

dparkinson
Level: Powered On

Re: Dynamic content always returns empty

Did you ever actually solve this?  There doesn't appear to be a resolution here?  

 

I'm experiencing the same issue and not sure how to fix it.  The Department field is blank for everything.

 

Thanks for any advice you can provide.

Mordikus
Level: Powered On

Re: Dynamic content always returns empty

Hello dparkinson, (sorry if my english is bad Man Tongue )

 

i didn't solve this in particular, i solved my problem in an other way as i found a solution to it , then,  i marked this post as solved, my bad.

 

i tried it again right now,

I can tell you that i still have the same issues, Created By Department & Created By job Title always returns empty,

 

so i can't help you 😞

 

 

in my case, as i'm using this flow with a sharepoint environment, i calculated the department from within my sharepoint environment and i get it back as a basic value from a custom list,

 

Have a good day

Anonymous
Not applicable

Re: Dynamic content always returns empty

Getting this problem too. Email and DisplayName working fine, but Job Title returning empty.

 

Don't think this it's an issue with my profile as PowerApps is able to pick up on the user job title just fine. Anyone care to share their workarounds for this?

Dandalf
Level: Powered On

Re: Dynamic content always returns empty

i am also getting this problem. I have three flows in use in our production environment - variations of sending mails and getting approvals - and they all work fine except a new one I made today. I've tried to delete and re-make both the list and the flow. What's strangest is that *some* dynamic fields populate the email, but some do not. The flow returns as successfully run, though of course it has not.

Gbolahan
Level: Powered On

Re: Dynamic content always returns empty

Hi every one

I have the same challenge

I want outlook to send an email everytime I modify an excel file on onedrive

But the content and subject of the email is always 0

Screen Shot 2017-08-16 at 11.57.23 AM.pngThe column I want returnedScreen Shot 2017-08-16 at 12.14.14 PM.pngThe flow with emphasis on the subject and bodyScreen Shot 2017-08-16 at 12.13.14 PM.pngActionBranchingConditionNotSatisfied Error message

Any one with any solution

 

Thank you

Anonymous
Not applicable

Re: Dynamic content always returns empty

I'm having this same issue.  Has anyone found a solution???

jemsann
Level: Powered On

Re: Dynamic content always returns empty

I found a workaround; instead of using "Created by department", add an action called "Get user profile". In that action, add "Created by Email" and then use the results from the new action in the main action.

Capture.PNG

 

 

 

lallison
Level: Powered On

Re: Dynamic content always returns empty

Hi

 

Any updates, I am having the same issue

 

Linda

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 349 members 5,563 guests
Please welcome our newest community members: