cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AbbyD
Advocate I
Advocate I

Dynamic content not displaying in output

Hello! I have already searched for a solution to this issue, and this existing "solution" did not work for me.

 

I have some scoped controls to provide better automation. My issue is that my dynamic content outputted from previous steps displays correctly in one scope but not the other. For example, one scope it just displays @{outputs('Convert_email_to_7-letter')}) instead of the actual content outputted from that previous step.

 

I've tried putting the needed action (post a slack message) in an "apply to each" section, but it doesn't seem to matter if it's in there or not. The same thing happens either way.

 

Any guidance is much appreciated! 

 

How my flow is set up:

flow input setup.png

 

 

 

What it outputs:

flow output wrong.png

1 ACCEPTED SOLUTION

Accepted Solutions

Hi! Yes, I did re-create the step. I did not copy-paste or type out the content I wanted, though the screenshot makes it look like I did. After selecting what I needed from the dynamic field options and saved, the form converted the dynamic content selection to the text you see in the screenshot. No matter how many times I re-selected it from the dynamic content options, it always got converted back to text. 

 

My issue is "resolved"--with no changes from me, it just started working after a few days. 🤔 Really hope that's not a common problem to reoccur, as my team relies on this functionality to manage our workload.

View solution in original post

3 REPLIES 3
Jcook
Super User
Super User

Hello @AbbyD
Have you tried deleting the action and recreating?

Did you copy and paste the content?
You cannot copy and paste dynamic content.

—Josh
If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





v-bacao-msft
Community Support
Community Support

 

Hi @AbbyD ,

 

If it is an expression, you need to edit it in Expression and then apply it to the field.

Just pasting expression doesn't work.

When editing in Expression, you need to remove the preceding @.

129.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi! Yes, I did re-create the step. I did not copy-paste or type out the content I wanted, though the screenshot makes it look like I did. After selecting what I needed from the dynamic field options and saved, the form converted the dynamic content selection to the text you see in the screenshot. No matter how many times I re-selected it from the dynamic content options, it always got converted back to text. 

 

My issue is "resolved"--with no changes from me, it just started working after a few days. 🤔 Really hope that's not a common problem to reoccur, as my team relies on this functionality to manage our workload.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,534)