cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Dynamics 365 triggers not triggering

I have a flow that is triggered when a Dynamics record is created or updated, but it doesn't trigger until I go to the flow and turn it off and back on again or edit flow->save.

flow.PNG

 

 

 

Not facing the same issue for other triggers (like Twitter), so guessing nothing to do with license.

I am using the latest version of Chrome as as browser, our network activity is very good

The dynamics instance that I am testing on is TIP (Test in Production) for Dynamics CRM developers.

 

 

 

Is there any way to find out the reason for flows and triggers not working or taking a long time to start?

 

This unreliability makes it very difficult to leverage the same and demonstrate it's potential to any senior members of staff.

 

 

6 REPLIES 6
Community Support Team
Community Support Team

Re: Dynamics 365 triggers not triggering

Hi @sandeepnmenon,

 

The issue could not be reproduced by me.

According to your description, I have created a simple flow to send out a push notification when a dynamics record is updated. It will be triggered once a record in the specified entity is updated.

There is no need for me to turn it off and back on or edit the flow.

I am using Edge, and Production instance for testing.

1.PNG

Which Flow Plan are you using?

If you are using trigger for Dynamics 365 – When a record is created, will it have the same issue? 

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Re: Dynamics 365 triggers not triggering

 Hi @v-yamao-msft

 

I am using "Microsoft Flow Free" product license, which as per my understaning does 5-min checks. I have waited for more than that time. And as soon as I do a blank edit-save, the flow is triggered.

 

Yes, the same issue for "record is created" trigger as well.

Matt_Taylor
Level: Powered On

Re: Dynamics 365 triggers not triggering

If it helps I am getting the exact same issue - the flow will not run unless I disable and then enable the Flow (I've waited several hours even though we should be on the P2, 1 minute refresh). 


Microsoft, any ideas? This is a deal-breaker for us

garda
Level: Power Up

Re: Dynamics 365 triggers not triggering

Hi guys,

have you been able to fix the issue? I'm having exactly same problem

Matt_Taylor
Level: Powered On

Re: Dynamics 365 triggers not triggering

I have to admit I didn't follow up on the Microsoft response yet (sending copy of Flow and Flow plan etc.) but I did find a workaround that suited our needs:

Rather than using the Dynamics 365 connectors I used the Common Data Service connectors and they all seem to trigger without issue - I believe we're on P2 so we see most of these run instantly but not more than a minute as promised. 

Highlighted
garda
Level: Power Up

Re: Dynamics 365 triggers not triggering

I have done exactly the same. Colleague from Microsoft recommended me to use the CDS connectors instead the D365 connectors in MS Flow.

It helped.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (6,910)