cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mwinner
New Member

E-mail > Teams Post > Acknowledge > Flow > Push

To outline what is happening (or what I want to):

  1. E-mail is received in folder
  2. Flow posts message card to specific channel in Teams
  3. Card has an action button that is used to alert management it was picked up
  4. Acknolwedgement is sent back to flow
  5. Communication sent back in some platform, e.g., text, e-mail or push.

 

I've got the 1, 2, and 5 setup, but struggling on 3. I tried doing an HTTP Post back to Flow's URL, but I get an "HTTP Unauthorized" error. How can I overcome this, and is it possible to simply have an action button that captures the user's name that clicks it to be sent off with the HTTP Post?

 

Here's my JSON so far with some elements stripped out:

 

{
"@type": "ActionCard",
"@context": "http://schema.org/extensions",
"themeColor": "0076D7",
"summary": "New Critical Case Submitted to Group",
"sections": [
{
"activityTitle": "New Critical Case Submitted to Group",
"activitySubtitle": "Please reply to @Support (O365 Group) when you've assigned yourself the case",
"activityImage": "IMAGE",
"facts": [
{
"name": "Subject:",
"value": "Test"
},
{
"name": "Details: ",
"value": "Test2"
}
],
"markdown": true
}
],
"potentialAction": [
{
"@type": "ActionCard",
"name": "I got it",
"inputs": [
{
"@type": "TextInput",
"id": "assigneeName",
"title": "Enter Your Name"
}
],
"actions": [
{
"@type": "HttpPOST",
"name": "OK",
"target": "FLOWURL"
}
]
}
]
}

3 REPLIES 3
v-yamao-msft
Community Support
Community Support

Hi @mwinner,

 

The HTTP unauthorized client error status response code indicates that the request has not been applied because it lacks valid authentication credentials for the target resource.

Please make sure your JSON contains required elements.

Besides, please check the following blog on how to fix unauthorized error at here:

https://airbrake.io/blog/http-errors/401-unauthorized-error

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I can make the same call with Postman without issue, but Teams fails. What exactly am I missing in my JSON?

@v-yamao-msft Any input on my previous ask?

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (78,818)