cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RasaLT
Frequent Visitor

Editing datacard in powerapp resets approval status

Hello flow-ers,

I have made an Powerapp in our oragnisation for absence approval with the flow to SP, which works just fine. Until we have encountered an interesting issue which I did not noticed when I tested the app.  

 

In the admin site I have made a possibilityt to edit form of each absence record, that admin could mark which absences where transfered to our ERP system to make the process a bit easier until we have a new ERP seted up.

 

The mark is just one column in the SP list (no->default). Since the mark is changed (no -> yes) the status - from approved to pending was automatically changed. Does anyone have an idea how to solve this issue or go around it ?

approval.jpg

 

 

3 REPLIES 3
v-alzhan-msft
Community Support
Community Support

Hi @RasaLT ,

 

Could you please share a screenshot of the configuration of your flow?

Does your flow would change the status to pending when the item is modified? If yes, you could add a condition under the trigger to prevent the status to be changed.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Alice,

 

My flow looks like this: 

flow.jpg

 

 

 

 

 

 

 

Question: Does your flow would change the status to pending when the item is modified? 
Yes - unfortunately it does, if any other attribute of the item is changed (not status itself) then it status is reseted to 'pending'

 

If yes, you could add a condition under the trigger to prevent the status to be changed.

Would you have an example for the condition like that?

In the mean time I have solved the issue by adding a toggle in the item of a gallery and it kind of disables the title in order to signal for admin that this item is already transferred to the system (green title - approved, but not transferred into the system, grey - (should be approved) and transferred into the system, Black - pending, not transferred into the system):

toggle.jpg

which solves the issue for now, but it is not too elegant.. 

p.s. I am pretty new in this area

RasaLT
Frequent Visitor

This doesn't work, as the toggle, doesn't stay as it was set; even though if disabled reset option.

 

Still no good solution

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,939)