cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JasonLane
Helper III
Helper III

Email Approval Process not Working

Good Afternoon,

I have built a process flow for Approval.

The process needs to look at a SQL database and return an email address from the line of data in the 'AssignedTo' section of the flow. When completing the flow as below i receive and error which i have provided as well?

Approval Process.JPGApproval Error.JPG

 

Any help is appreciated as I'm at a loss?

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
JasonLane
Helper III
Helper III

Hi,

The error came from NULL values in the existing ManagerEmail Column. Once this has been updated with information the flow worked.

Thanks @emadrigal 

View solution in original post

3 REPLIES 3
emadrigal
Microsoft
Microsoft

Hi @JasonLane 

 

This usually happens if the field value specified in the 'AssignedTo' section is empty. You could add a Condition first to determine if Manager Email dynamic content is empty. If it is empty, Approval action is not executed and if it is not empty, send an approval email.

 

First Step in the flow:  When an item is created (as you did in the picture)

 

Second Step in the flow: Add Condition (you need to add this part to your flow)

 

If manager email is equal to null

 

If yes   ---->  Take no action

If no   -----> Create an approval (as you did in the picture)

 

Let me know if it this helps you!

 

Regards,

 

Community Support Team - Edgar Madrigal

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

JasonLane
Helper III
Helper III

@emadrigal  I have looked in to the table that feeds this process and imparticular the 'ManagerEmal' section and there is and email address in the table - i have tried you addition but it did run and it should have as there is an email address as shown below

JasonLane_0-1664351886486.png

Im at a loss now - The format of the data is varchar(255) as well if that helps.

Thanks

JasonLane
Helper III
Helper III

Hi,

The error came from NULL values in the existing ManagerEmail Column. Once this has been updated with information the flow worked.

Thanks @emadrigal 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (2,700)