cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Spamrancher
Resolver I
Resolver I

Email Message - Set "From"

I'm sending automated emails using the Office 365 Outlook "Send an email (V2)" action. That works fine. What I also want to do is record that I sent the email on the Case. I'm using the CDS "Create a Record" action and setting the Entity Name to "Email Messages".  The "From" box says "Sender of the email.", but no matter what I try, the "Sender" field in the Output is always null. 

 

Here is what I've tried that has not worked:

  • Text - "me@me.com"
  • My user GUID 
  • systemuser(my user GUID)
  • /systemuser(my user GUID)
  • mailbox(my mailbox GUID)
  • /mailbox(my mailbox GUID)
  • Get the email from Office 365 Outlook "Get Emails (V3)" action and passing the "From" field. (Description says "The mailbox owner and sender of the message.")

 

I've found a few posts from 2019 that show being able to set the Activity Party, but the Action no longer offers me that option.

 

Anyone know the secret to populating the From field? (The To field is giving me the same problems, but it's not as much of a concern to me.) There seems to be no documentation (that I can find) on the Email Message entity.

4 REPLIES 4
fchopo
Super User
Super User

Hello @Spamrancher 

Have you tried to use Contacts(your user GUID) ?

 

Hope it helps!

Ferran

 

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
v-litu-msft
Community Support
Community Support

Hi @Spamrancher,

 

I tried on my side to insert a value into the From field when creating a CDS record, but it did not work either.

As a workaround, you could create a custom Email field named EmailFrom, then try it again, for example:

Annotation 2020-05-25 103848.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the suggestion, but that still doesn't solve my problem of "Email from" not showing any information. Is this something that should be reported as a bug?

Annotation 2020-05-26 202719.png

 
 

Thanks for the suggestion. When I tried that it couldn't find a Contact with my System User GUID, which I suppose is not surprising.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,118)