cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
cameronhellmuth
New Member

Email link to file in Teams (Sharepoint)

I have a flow created to automatically send an email out with a shareable link on certain days in the morning. However, I can't seem to get the Item ID to work. I assume this is the Document ID? Where do I get the code to put into the "Item ID" field? When I put the Document ID of the file from Sharepoint there the flow fails. See screenshot below.

 

flow.png

1 ACCEPTED SOLUTION

Accepted Solutions
rsaikrishna
Community Champion
Community Champion

@cameronhellmuth 

 

Browse your SharePoint site and then open Documents library.

 

Edit the default view of the Documents library:

3.JPG

On clicking "Edit current view", you will see all the columns and select ID column.

4.JPG

Click on Save view. Now, you will see ID column in the view. 

2.JPG

Note down the ID value associated with your desired file.

 

Please let me know if you have any more questions.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.

View solution in original post

4 REPLIES 4
cameronhellmuth
New Member

Here's the error message I am receiving when I test the flow.

 

"The expression "sites('root')/lists('12ffa9f5-94e4-4526-9cda-81b2e4df5855')/items/4Q2KUWVCR2P6-1825696993-10043/driveItem/createLink" is not valid."

rsaikrishna
Community Champion
Community Champion

@cameronhellmuth 

 

Browse your SharePoint site and then open Documents library.

 

Edit the default view of the Documents library:

3.JPG

On clicking "Edit current view", you will see all the columns and select ID column.

4.JPG

Click on Save view. Now, you will see ID column in the view. 

2.JPG

Note down the ID value associated with your desired file.

 

Please let me know if you have any more questions.

 

Regards

Krishna Rachakonda

If this reply helped you to solve the issue, please mark the post as Accepted SolutionMarking this post as Accepted Solution, will help many other users to use this post to solve same or similar issue without re-posting the issue in the group. Saves a lot of time for everyone.

Thanks @rsaikrishna! That resolved my problem. I really appreciate the help.

emseki
Community Support
Community Support

Thank you for sharing your issue, this thread helps others.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (1,196)