cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Roberts2727
Helper IV
Helper IV

Email notification flow fails when attachments are added

I have created a flow which sends an approval on submission to sharepoint list, then after the approval, sends an email to the worker to process the request. In the email to the worker I am adding in attachments submitted to the list item.

 

When sending the email to the worker after the approval the flow fails

 

No input parameters provided. Please provide required input parameters 'To', 'Subject' and 'Body'.  

 

If i remove the attachmentArray I created then the message is sent fine. please help!

1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

Hi @Roberts2727,

 

Do you want to get multiple attachments from SharePoint list item and send them to user as attachments within email?

Could you provide a full screenshot of your Flow configuration?

It seems that the problem may be the configuration of some action.

In addition, please check the following blogs and see if it would help:

http://saltypc.com/?p=619

https://flow.microsoft.com/en-us/blog/multiple-attachments-single-email/

I tested it according to the contents of the article and found that I need to make some changes to the configuration of the Append to array variable action. Then it work.

34.PNG

And if you want to get multiple attachments in the list item, you may need to use the Delay action to wait for some time response. 

Please take a try and let me know if issue still exist.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Roberts2727
Helper IV
Helper IV

Capture.PNG

v-bacao-msft
Community Support
Community Support

Hi @Roberts2727,

 

Do you want to get multiple attachments from SharePoint list item and send them to user as attachments within email?

Could you provide a full screenshot of your Flow configuration?

It seems that the problem may be the configuration of some action.

In addition, please check the following blogs and see if it would help:

http://saltypc.com/?p=619

https://flow.microsoft.com/en-us/blog/multiple-attachments-single-email/

I tested it according to the contents of the article and found that I need to make some changes to the configuration of the Append to array variable action. Then it work.

34.PNG

And if you want to get multiple attachments in the list item, you may need to use the Delay action to wait for some time response. 

Please take a try and let me know if issue still exist.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for the reply Barry. I found that using body('Get_attachment_content').$content in the append to array variable was the key. Flow is working properly. 

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (5,090)