cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SPDevelKMT
Level: Powered On

Emails sent from a list are using Shared Mailbox name from a different list\flow

I have a Flow(FLOW1) running on List1 that is triggered when an Item is Created or Modified.  Within the flow I am sending an email.

 

I also have a different Flow(FLOW2) running on a list(LIST2) in another site collection that is in no way related to Flow 1 or List 1. FLOW2 has the From field in the send and email action set to a Shared Mailbox (NDA Mailbox).

 

The issue is that when FLOW1 runs and sends the email from List1, the from address is the NDA Mailbox from FLOW2\LIST2.

 

The ID I am using is a global admin and the flow will not allow me to set the From address to my global admin email even though all the connections in all the flows are using the global admin address.  Getting the "cannot send as another user"error.   I cannot set the from to created by email either.  I think I can fix it by creating a shared mailbox, but that seems crazy. The site is a new team site connected to a group so I already have an email address for the site.  I have already tried adding the group email address and that is not supported at this time Uggghhhh!

 

At this point I would be fine if the email came from the old default noreply@sharepointonline.com address. 

 

This is definetly a bug.  To reproduce you would:

 

Create a flow on a list and change the from address on the send an email action to a shared mailbox.

Create a flow on another list and add the send an email and see if it comes from the shared mailbox from the other list.

1 ACCEPTED SOLUTION

Accepted Solutions
SPDevelKMT
Level: Powered On

Re: Emails sent from a list are using Shared Mailbox name from a different list\flow

I found th solution for this problem.  On the send an email action within flow, click on the three dots on the heading.  In the My connections area there are all connections for all flow.  The incorrect connection was automatically selected in the My Connections settings.  I did not change that setting, it was defaulted that way.  After choosing the connection for the account that created the flow, the from address in the emails sent from the send an email action came from the correct address.  Hope this helps someone, seems to be a bit of a bug.


Connections.jpg

 

 

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Emails sent from a list are using Shared Mailbox name from a different list\flow

Hi @SPDevelKMT,

 

About Flow1, have you set the From field with a specific email address?

 

For Flow2, have you tried to enter a specific individual email address in the From field to see if it will work?

 

Please share some screenshots on this issue, I am trying to reproduce it on my side.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
SPDevelKMT
Level: Powered On

Re: Emails sent from a list are using Shared Mailbox name from a different list\flow

Flow1 ifrom address blank

 

Yes

 

There is really not anything to share except for the send and email action with the advanced option open.

SPDevelKMT
Level: Powered On

Re: Emails sent from a list are using Shared Mailbox name from a different list\flow

I just created another flow in a completely different sc and list than the last two described above.  The new flow has a send an email action and it is also has the from address set to the Shared Mailbox from FLOW2.  The From address is blank

 

I am going to open a ticket with premier support.

 

image.png

SPDevelKMT
Level: Powered On

Re: Emails sent from a list are using Shared Mailbox name from a different list\flow

I found th solution for this problem.  On the send an email action within flow, click on the three dots on the heading.  In the My connections area there are all connections for all flow.  The incorrect connection was automatically selected in the My Connections settings.  I did not change that setting, it was defaulted that way.  After choosing the connection for the account that created the flow, the from address in the emails sent from the send an email action came from the correct address.  Hope this helps someone, seems to be a bit of a bug.


Connections.jpg

 

 

View solution in original post

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (5,592)