cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ryans32229
Frequent Visitor

Embedding image into new email, where image is from previous email

Hi all,

 

I'm currently triggering when an email is received, then trying to grab the attachment from that email and send it out embedded in the body of a new email. Here's my current flow:

 

image.png

 

I want to use HTML in the body of the outgoing email (I have HTML turned on in advanced options). How do I integrate the dynamic content from the incoming email into the HTML of the body of the outgoing email? Testing the above only fills the email with symbols.

 

Thanks

 

 

14 REPLIES 14
v-yuazh-msft
Community Support
Community Support

Hi @ryans32229,

 

You couldn't insert the Content dynamic content of the trigger in the Body field of "Send an email" action to Embed image into new email.

 

Embedding image into a email body is not supported in microsoft flow currently,

I afraid that there is no way to achieve your needs in Microsoft Flow currently.

 

If you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

As an alternative way,please take a try to send the email as an attachment of the new email,the sceenshot of the flow as below:

Capture.PNG

 

Best regards,

Alice

Hi @v-yuazh-msft

 

In this thread they are able to embed an image into the email body: https://powerusers.microsoft.com/t5/General-Flow-Discussion/insert-picture-outlook-body-message/td-p...

 

Are you saying it's not possible for dynamic content from the trigger? In that case could the Flow save the attachment to OneDrive or Sharepoint and then look for it in there, then embed it as in the above thread?

 

Thanks

 

Hi @ryans32229,

 

I have made a test on my side, and couldn't acheive to embed an image into the email body following the thread that you mentioned,the image into the email body would always be a red "X", and I afraid that it is not supported in microsoft flow currently.

 

Best regards,

Alice

Hi @v-yuazh-msft

 

I see, so in the thread I linked, Flow has removed the functionality to embed an image into an email with HTML?

Hi @ryans32229,

 

Yes, I afraid it is be removed.

 

Best regards,

Alice

Alice,

Your statement:


 

Embedding image into a email body is not supported in microsoft flow currently,

I afraid that there is no way to achieve your needs in Microsoft Flow currently.

 


seems absolute.  Could you provide a link where this position is clearly stated by Microsoft?

 

Thanks,

Stephen

FlyingDutchman
Advocate I
Advocate I

The best way is to attach the image as attachment and add some html code to your body where you want to display the image. 

Step 1:

use "Send an email (V2)"

 

Step 2:

click on "</>" in the body field to show the HTML editor.

 

Step 3:
Add the following code: "<img src="header.png" alt="header" />"

 

Step 4:

Add an attachment:

Attachments Name - 1 : header.png

Attachments Content - 1: content of the image

 

You can add as many image as you like 🙂

 

 

 

@FlyingDutchman , success to read the msg in o365 using your method. However, when I open the mail in outlook desktop version, it shows X. May I know if there is any solution for this, thanks.

 

PS. I have follow below steps, but still shows X

https://www.nucleustechnologies.com/blog/cannot-see-images-in-outlook-emails-this-post-will-definite...

@FlyingDutchman You have the real answer to this question. This answer worked like a charm and was simple to do. Make sure y'all use binary as the file content. May use the base64ToBinary() expression

This is SO HELPFUL. Thank you so much. 

I am hitting one more issue. My email source has only ONE attachment but it runs twice each time as if it has 2. Flow doesn't let me remove the Apply to each. 
Any idea on how to solve this ?

Best,
Dorette 

How do I get the content of image?

i am not getting any of these to work.

Something this simple should not be this difficult 😞

@DragonLord 

 

Follow below link. Both the solutions mentioned there worked for me.

 

https://powerusers.microsoft.com/t5/Building-Flows/Unable-to-embed-an-image-within-email-using-the-a...

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (22,513)