cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper V
Helper V

Error icon from select, making it impossible to correct and save. (BUG)

Came across this behaviour when attempting to add some custom json to the select map

 

First i noticed that the dynamic content was missing when enabling "json mode" in the editor:

Missing dynamic content and expression options in "json mode"Missing dynamic content and expression options in "json mode"

Dynamic content and expressions are visible in "regular mode":

dynamic content available in "regular mode"dynamic content available in "regular mode"

if providing nothing in the "json mode" and switching back to "regular mode" it can sometimes produce this situation:

error indication that locks the editorerror indication that locks the editor

I can't delete or move (not dragable) the faulty selection step with the exclamation mark, so the only way to be able to save the flow is to delete the parent scope, or "apply to each.." in this case. And I have to create a new apply to each to then drag all the other actions within to the new apply to each if I wish to salvage the work. 

 

Also please note that this behaviour is inconsistent! I am occasionally able to recover the action to recover it by minimising the parent scope or "apply to each" but this is also not always the case. 

 

I am using Chrome, but this has not been an issue before.

2 REPLIES 2
Highlighted
Super User
Super User

Re: Error icon from select, making it impossible to correct and save. (BUG)

i have seen this with email actions too, you can recover by copy/pasting another action which does a slight refresh which helps the situation

Highlighted
Helper V
Helper V

Re: Error icon from select, making it impossible to correct and save. (BUG)

Thanks for the suggestion @Gristy 

 

I've been away for a few weeks, and it seems that a lot has been updated and there seems to a fair amount of bugs in the editor now. Have you also experienced issues with the dynamic content and expression pane? Its not showing, in some cases but there is also an issue with the "see more" button: 

not showing hidden functions when clicking "See more"not showing hidden functions when clicking "See more"

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (8,300)