cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ay2
Helper II
Helper II

Error that makes 0 sense

Created real small flow to test - high level idea

1.) A file is created in a SharePoint list (relatively empty)

2.) The item gets updated at different times on different columns, but nothing happens until a specific column gets updated

3.)When that specific column gets updated, create a file with that specific column as the name, and the other fields as the contents

 

In the create file step, I cannot add ANY of the dynamic fields given to me, the flow gives me an error. In either get item, in the creation or modified step. I've used flows before and made the "create a file" work many times, but it's never given me an error when using the dynamic content.

ay2_0-1594903668119.png

ay2_1-1594903693841.png

 

 

5 REPLIES 5
v-litu-msft
Community Support
Community Support

Hi @ay2,

 

You could put these dynamic content into a Compose action, then put body of compose action into the Create File action to check it whether work.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-litu-msft 

 

Thanks for the reply. Yes - eventually after playing around with it for an absurdly long time, I ended up doing that as a workaround. But the issue still stands, don't understand why this gives me an error in the first place. Would be much more efficient if the picture attached works

v-litu-msft
Community Support
Community Support

Hi @ay2,

 

I tested it serval times but couldn't reproduce the issue you met, it is maybe an inner flow checker issue.

Are you create the Flow from a template? If so, please delete the action then recreate a new one and try it again.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It's funny because what I tried to accomplish, it worked on another flow, but did not work in this flow. I tried refreshing this a dozen times and came to the same result. I create almost all my flows from blank - no template so I'm not sure.

v-litu-msft
Community Support
Community Support

Hi @ay2,

 

Yes, it's weird and worth to notice, I will give more attention to this issue, if it happened on my side, I will report it to MS PA development teams.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,543)