cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Error with Excel connector

I create a flow and i have 2 issues:

 

1.  When add Excel connector: after choose location, i couldn't choose document library and display error message

401 unauthorized

2. I delete environment using at error 1, and create new environment, i step by step add Excel Connector and display below message. 

error.png

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @greenfire,

 

You could try these methods to solve your problem:

1. Log out the Power Automate account and log in back;

2. Create a new Excel connection in the Connection center;

3. Clear cache of the browser;

4. Using other browsers to open the Power Automate, such as Chrome, Microsoft Edge (Chromium).

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Super User II
Super User II

Hello @greenfire 

Do you have read permissions on the document library where the excel file is stored?

Could you provide more detailed information? (trigger and idea of the flow)?

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

 

hi @fchopo 

my Excel file store in my onedrive or my sharepoint folder, so i have all permission.

I want to read all rows of excel file and add to sharepoint list.

With my onedrive business:

error1.png

With my sharepoint folder:

error2.png

Hello @greenfire 

Could you try to review or recreate the connection to Excel? Have a look at this thread: https://powerusers.microsoft.com/t5/General-Power-Automate/add-a-line-to-excel-status-401-unauthoriz...

 

Hope it helps!
Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

Hi @greenfire,

 

You could try these methods to solve your problem:

1. Log out the Power Automate account and log in back;

2. Create a new Excel connection in the Connection center;

3. Clear cache of the browser;

4. Using other browsers to open the Power Automate, such as Chrome, Microsoft Edge (Chromium).

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (8,041)