cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ianallen13V2
Helper II
Helper II

Error with Flow - can someone review? Only sends when there is an attachment present apparently...

Hello, 

 

I have a workflow built and it works fine when there is an attachment included, but when there is not, it still says that it 'succeeded' but there is no email sent.  Not sure what I am missing.  I've done workflows like this before without this being an issue, so it has to be something small that I am missing.  Any help is appreciated: 

 

Part 1Part 1part 2part 2part 3part 3

1 ACCEPTED SOLUTION

Accepted Solutions

Testing for Boolean values is case sensitive.  The best way to do it is to put the True enumeration in the right side using the expression tab.  Like this

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
Pstork1
Dual Super User
Dual Super User

I assume your Apply to each is based on the body of Get attachments.  Since the email is sent inside that apply to each, if there are no attachments the Apply to each doesn't run and there is no email.  You need to add a condition just after the Get attachments and see if there are any attachments.  If there are then do what you do now.  If there aren't then send the email.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Hello, 

 

I just tried that and I'm still running into issues.  I added a condition where if 'Has Attachments' is equal to, and I tried 'FALSE, TRUE or just left it blank' and it keeps saying that it bypassed the second email and that everything ran successfully.  

 

Here is a picture of the condition.  Do I have the right field selected and/or what value should I choose?  

 

attachment.jpg

Testing for Boolean values is case sensitive.  The best way to do it is to put the True enumeration in the right side using the expression tab.  Like this

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
ianallen13V2
Helper II
Helper II

That was it - thank you so much!! 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Users online (4,304)