cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Post Partisan
Post Partisan

Errror: A value must be provided for item

Hello,

 

I'm trying to create a simple flow that sends an email whenever a new row is added to a table of an Excel file.

It all looks good, but when the flow is executed, I get the error:

 
Errror: A value must be provided for item\r\nclientRequestId: e5d51f92-ba7e-4dfe-9dd1-d56d723978f8",
 
I have no idea what this means, but found another post with a similar question, that was solved by recreating the flow again. Tried that too.
 
image.png
Any help would be appreciated, thanks in advance!
13 REPLIES 13
Highlighted
Super User
Super User

Hi again @WebPortal  🙂 Can you please post a screenshot of the failing action config?





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

Highlighted

Hi @MattWeston365 

 

Here it is:

 

image.png

Thank you.

Highlighted

Hi @WebPortal 

 

Looks like you are passing all the right parameters. Could you try remove and add the step again?

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog

Power Automate Video Tutorials
Highlighted

 

Hi @WebPortal ,

 

Could you please show us the specific configuration in Add a row into a table action?

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

@v-bacao-msft 

 

Here it is:

image.png

Highlighted

@v-bacao-msft @MattWeston365 

 

Any ideas to solve this (apparently) simple issue ..?

Highlighted

Hi @WebPortal apologies I've not been able to get on for a couple of days due to travelling. The issue is because you're not providing any inputs into the Excel workbook. You need to provide an input to a cell, it can't enter a blank row.





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

Highlighted

Hello,

 

Thank you so much for helping.

 

I now try to use the app that feeds this flow and I get another error:

 

image.png

Highlighted

@MattWeston365 @v-bacao-msft @abm 

Thanks for helping.

The app is now working fine. For every form submission, it adds a row to an Excel table, no problem.

But why is the flow not working? It only has to send me an email notification whenever someone submits a form entry.

 

Here's a full screenshot of the error:

 

image.png

Highlighted

Hi @WebPortal is this the correct screenshot as it is showing the same error as what we had before, when there wasn't an entry being put into the workbook table.





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

Highlighted

 

Hi @WebPortal ,

 

I noticed that the Excel table contains the _PowerAppsId_ field. Is it a required field? You could try to delete this field, then reconfigure Add a row into a table action and see if a similar error still exists.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hello @v-bacao-msft @MattWeston365 @abm 

 

When I try to run the app now, I go back to the same error I had yesterday, although it had already disappeared when the spreadsheet was shared with everyone in the company with the link and allowed editing.

 

So it was working and adding rows to the table!

 

Anyway, the error is back again, and I have no idea why because I didn't change anything:

image.png

 

We created this app for a customer so that users could share their feedback about the Power BI report. 

 

It shouldn't require that much complexity, but still it's not working, and I'm realizing now this is just crap and a complete waste of time.

Highlighted

This looks the same as an error we saw several times. It appears to be related to intermittent environmental conditions as there was a short period of about an hour that our flow failed with this error every couple of executions -- but then the 100 or so executions since then have all been without error.

 

i_power_0-1592937571045.png

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (10,998)