cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Excel Online - BadGateway

I created a Flow where one of the actions is 'create table' with the Excel (business) connector. Since a few days/weeks the Flow seems to fail with the error message 'BadGateway'.

The document where I want to create a table in is stored in the OneDrive of the same account. This is a recurring Flow running every 3 hours.

 

Is there a workaround for this issue?

 

raw body output from the failed action:

{
  "error": {
    "code": 502,
    "source": "flow-apim-europe-001-francecentral-01.azure-apim.net",
    "clientRequestId": "55bd7919-2827-40a4-95e4-68ccc5e72839",
    "message": "BadGateway",
    "innerError": {
      "status": 502,
      "message": "Graph API is currently unavailable.\r\nclientRequestId: 55bd7919-2827-40a4-95e4-68ccc5e72839\r\nserviceRequestId: d429818b-ef99-4d45-84cb-c6236e2f8491",
      "source": "excelonline-we.azconn-we.p.azurewebsites.net"
    }
  }
}

 

Thanks in advance.

 

 

 

4 REPLIES 4
Community Support
Community Support

Hi @Rens_ ,

 

Does your problem still exists?

If the error code 500 or 502 appears, the failure is temporary or transient. Please click or tap Resubmit to try the flow again.

Please let me know if your issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This is a recurring Flow running every 3 hours. This Flow fails every time it runs with the same error.

Regular Visitor

Hi

 

i have the same error when i try to read an excel from Sharepoint document

 

 

{
"error": {
"code": 502,
"source": "flow-apim-europe-001-francecentral-01.azure-apim.net",
"clientRequestId": "7a115457-0adf-47d0-a954-b556123b9086",
"message": "BadGateway",
"innerError": {
"status": 502,
"message": "Graph API is currently unavailable.\r\nclientRequestId: 7a115457-0adf-47d0-a954-b556123b9086\r\nserviceRequestId: 6e66b8bd-d9a7-4b01-ab42-afea6539f741",
"source": "excelonline-we.azconn-we.p.azurewebsites.net"
}
}
}

Did you ever find a resolution to this? I tried creating a new excel file by copying all the tabs from the old excel into the new one then saving it on sharepoint. At this point the flow works fine. I leave it for some minutes then re-run exactly the same flow against exactly the same file only to get the badgateway error again! OneDrive is being used to replicate the excel file to my laptop. Is there any chance that the replication is somehow modifying the excel file such that it then refuses to work with Flow? I tried running the same call in Graph Explorer and it works fine.

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (4,565)