cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Skilled Sharer
Skilled Sharer

Excel actions - Error retrieving Table - "Could not retrieve values. BadGateway"

Hi, I am trying to use the excel action to List Rows present in a table, Delete a row, Add a row.  Unfortunately I'm getting bad gateway errors when trying to reference the table.  The excel file was created from an exported SharePoint list via iqy file.  

https://powerusers.microsoft.com/t5/Building-Flows/Flow-to-automatically-refresh-Excel-file-synced-t...

Anyone know how to fix this?

 

badgateway.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Responsive Resident
Responsive Resident

Hi @Brice235i , Have you formatted your document as a table first? This is necessary when working with Flow.

CT

-------------------------------------------------------------------------

Give a THUMBS UP if my comments was help or ACCEPT SOLUTION if this has solved your issue. Thanks

View solution in original post

3 REPLIES 3
Highlighted
Responsive Resident
Responsive Resident

Hi @Brice235i , Have you formatted your document as a table first? This is necessary when working with Flow.

CT

-------------------------------------------------------------------------

Give a THUMBS UP if my comments was help or ACCEPT SOLUTION if this has solved your issue. Thanks

View solution in original post

Highlighted
Community Support
Community Support

 

Hi @Brice235i ,

 

First, you need to specify Excel file from File browse, you should not manually enter File path.

Second, the specified Excel file requires an already defined Excel table.

Third, during the process of configuring Flow, make sure that the Excel file is not opened or is being edited.

Please try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

Hello, eventually figured it out.  I exported a list to excel.  Opened the query file, formatted as a table.  

This didn't work - bad gateway error when trying to locate the table.  

 

What I did was remove all list data except for the headers..  deleted the table.  Then I created a brand new table.  This fixed the problem.  thanks

 

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (9,484)