cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
hjaf
Level: Powered On

Expressions in a select action being stripped without warning

Is this a bug?

I have to change som data types to compare a couple of arrays with intersection() in an action later on, but using expressions in the select seems to be stripped away without warning, after i have successfully added them. The strip seems to happen if I go from key-valye mode to text-mode. 

image.pngafter the expression is added to the value fieldimage.pngafter clicking text-mode

the code view before I toggle input mode: 

{
    "inputs": {
        "from": "@body('Get_items')?['value']",
        "select": {
            "TAG": "@item()?['TAG']",
            "NOM_DIAM": "@string(item()?['NOM_DIAM'])",
            "PIPING_CLASS": "@item()?['PIPING_CLASS']",
            "INSULATION_CLASS": "@item()?['INSULATION_CLASS']",
            "ID": "@item()?['ID']",
            "OPER_TEMP": "@string(item()?['OPER_TEMP'])",
            "OPER_PRESS": "@string(item()?['OPER_PRESS'])",
            "OP_CRITICAL": "@item()?['CRITICAL']?['Value']",
            "OP_COMMENT": "@item()?['COMMENT']",
            "OP_SAFETYMEASURE": "@item()?['SAFETYMEASURE']",
            "OP_MEDIUM": "@item()?['MEDIUM']",
            "OP_H2S": "@item()?['H2S']?['Value']",
            "OP_AUTO_IGNITION": "@item()?['AUTO_IGNITION']?['Value']"
        }
    }
}
2 REPLIES 2
Community Support Team
Community Support Team

Re: Expressions in a select action being stripped without warning

 

Hi @hjaf ,

 

Thank for your feedback! And I can reproduce the same situation on my side.

The result of my test is that this will only happen when using string() function.

I suggest that you maintain a mode to configure the key and value when configuring the Select action. Use only text mode or just key-value mode.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
hjaf
Level: Powered On

Re: Expressions in a select action being stripped without warning

Thank you for your suggestion, but I believe it is the editor / ui that causes it. Simply reloading the editor (It seems even just saving or any other action that causes the action editor part to reload) will strip the string function. 

I am happy as long as the issue is recognized so that it will be fixed some time in the future 🙂 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,377)