cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper V
Helper V

Expressions in a select action being stripped without warning

Is this a bug?

I have to change som data types to compare a couple of arrays with intersection() in an action later on, but using expressions in the select seems to be stripped away without warning, after i have successfully added them. The strip seems to happen if I go from key-valye mode to text-mode. 

after the expression is added to the value fieldafter the expression is added to the value fieldafter clicking text-modeafter clicking text-mode

the code view before I toggle input mode: 

{
    "inputs": {
        "from": "@body('Get_items')?['value']",
        "select": {
            "TAG": "@item()?['TAG']",
            "NOM_DIAM": "@string(item()?['NOM_DIAM'])",
            "PIPING_CLASS": "@item()?['PIPING_CLASS']",
            "INSULATION_CLASS": "@item()?['INSULATION_CLASS']",
            "ID": "@item()?['ID']",
            "OPER_TEMP": "@string(item()?['OPER_TEMP'])",
            "OPER_PRESS": "@string(item()?['OPER_PRESS'])",
            "OP_CRITICAL": "@item()?['CRITICAL']?['Value']",
            "OP_COMMENT": "@item()?['COMMENT']",
            "OP_SAFETYMEASURE": "@item()?['SAFETYMEASURE']",
            "OP_MEDIUM": "@item()?['MEDIUM']",
            "OP_H2S": "@item()?['H2S']?['Value']",
            "OP_AUTO_IGNITION": "@item()?['AUTO_IGNITION']?['Value']"
        }
    }
}
2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Expressions in a select action being stripped without warning

 

Hi @hjaf ,

 

Thank for your feedback! And I can reproduce the same situation on my side.

The result of my test is that this will only happen when using string() function.

I suggest that you maintain a mode to configure the key and value when configuring the Select action. Use only text mode or just key-value mode.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper V
Helper V

Re: Expressions in a select action being stripped without warning

Thank you for your suggestion, but I believe it is the editor / ui that causes it. Simply reloading the editor (It seems even just saving or any other action that causes the action editor part to reload) will strip the string function. 

I am happy as long as the issue is recognized so that it will be fixed some time in the future 🙂 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,739)