cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
unfeomateo
Level: Powered On

FTP 400 error even though a file was created / copied

I want to copy a file from my file system to an FTP but I get a 400 error. I can copy the file or create a new file just fine using flow but the flow does error out even though it looks like it worked. I see the text file on my FTP as expected but with this error:

 

{
"status": 400,
"message": "An invalid request was made. Inspect the passed parameters and actions.\r\nclientRequestId: b327d0d6-b774-4fae-b39d-3114785104e8",
"source": "ftp-wus.azconn-XXXXXXX.net"
}
 
I am not able to find much online. This seems like a simple thing to do. 
 
Thanks for any help
11 REPLIES 11
Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

The trigger "When a file is added or modified" doesn't pick up files over 50MB if the content is asked for. If files over 50MB should be processed with retrieving the content, the trigger "When a file is added or modified (properties only)" can be used followed by the "Get file content" operation.

 

https://docs.microsoft.com/en-us/connectors/ftp/

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



unfeomateo
Level: Powered On

Re: FTP 400 error even though a file was created / copied

I have this problem when just having the FTP connector create a file from scratch, copy or get content. Also my test files have been 2-3k text files. 

Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

Thanks for your quick reply.

 

Could you please post your screenshot of run history?

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



unfeomateo
Level: Powered On

Re: FTP 400 error even though a file was created / copied

Does this help?

 0.png1.png2.png3.png

Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

Thanks for the screenshot. Do you have a comma in your file path?

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



unfeomateo
Level: Powered On

Re: FTP 400 error even though a file was created / copied

The folder I was given on the FTP does have a comma on one of the folder names. 

Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

Try removing the comma and check. If not try another folder without comma.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



unfeomateo
Level: Powered On

Re: FTP 400 error even though a file was created / copied

I Tried a folder without a comma and had the same error. A file is created with the 400 error

 

 

Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

Thanks for your reply. Could you delete the FTP connection which flow is using and recreate it.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



unfeomateo
Level: Powered On

Re: FTP 400 error even though a file was created / copied

I recreated the connector. Same exact problem. File is created with the 400 error.4.png

Super User
Super User

Re: FTP 400 error even though a file was created / copied

Hi @unfeomateo 

 

Thanks for your reply. Unfortunately I am running out of options. If you have Microsoft support its worth raising with via that channel.

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!



Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 350 members 6,596 guests
Please welcome our newest community members: