cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Failure when running an approval flow from a SharePoint list

hi, I created an approval flow from a SharePoint list using the template 'Request manager approval for a selected item' but it fails when it runs.

First 'Loading' is displayed and then an error message is displayed 'Sorry, something went wrong'.

In the run history of the flow there is nothing.

Can anybody help me please ? Thanks in advance.
Eric

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Failure when running an approval flow from a SharePoint list

Hi @Erick,

 

When using this template, by clicking the See all for Run history you got the error message “Sorry, something went wrong”. Could you show me a screenshot of the error message?


In your side, can the flow be triggered when an item is selected in a list? When testing this issue on my side, seems that it cannot be triggered when an item is selected. A screenshot likes below, there is no status under Run history though I have selected items to trigger the flow.

3.PNG

 

Please provide more details to help reproduce this issue on my side.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate II
Advocate II

Re: Failure when running an approval flow from a SharePoint list

hi Mabel,

Thanks for your response.

Run history is empty. Below all screenshots from the flow creation to the flow run:

 

Everything starts in a SharePoint Online list :

08-01-2018 09-30-59.png

I clicked Create a flow

 

08-01-2018 09-31-14.png

 

I selected Request manager approval...

 

08-01-2018 09-31-33.png

 

08-01-2018 09-31-49.png

I clicked Continue

 

08-01-2018 09-32-08.png

 

I clicked Create Flow

08-01-2018 10-10-23.png

08-01-2018 10-11-09.png

 

I selected an item in the list and clicked the Request manager flow

 

08-01-2018 10-11-18.png

 

Loading is displayed for a while

 

08-01-2018 10-11-34.png

 

Then the error message Sorry something went wrong

However the run history is empty:

 

08-01-2018 10-11-51.png

Clicking See all

 

08-01-2018 10-11-59.png

Voilà !

 

Highlighted
Advocate II
Advocate II

Re: Failure when running an approval flow from a SharePoint list

I have the issue in SharePoint Online with Google Chrome and not with Internet Explorer (11) or Edge.

But in IE11 the page 'My flows' is blank (nada), so I have to work with Chrome.

Conclusion : SharePoint works best with IE11 and Flow with Chrome: switching between 2 browsers is not the best experience!

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (5,238)