cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ThomasDK
Resolver II
Resolver II

Files are copied OK, but I get an error?!?

I'm cpoying files from one Team channel/SP Site (folder under General/Shared Documents of source site) to another. I'm doing this two times in a row and the only thing that differs is the source and destination folders. 

 

The overview:

ThomasDK_0-1636113640414.png

 

The details:

Raw output:

{"statusCode":404,"headers":{"Vary":"Origin","X-SharePointHealthScore":"2","X-MS-SPConnector":"1","X-SP-SERVERSTATE":"ReadOnly=0","DATASERVICEVERSION":"3.0","SPClientServiceRequestDuration":"16","SPRequestGuid":"8bc4f87b-d9d4-4122-8122-baf2a61cf2c3","request-id":"8bc4f87b-d9d4-4122-8122-baf2a61cf2c3","MS-CV":"e/jEi9TZIkGBIrryphzyww.0","Strict-Transport-Security":"max-age=31536000","X-FRAME-OPTIONS":"SAMEORIGIN","Content-Security-Policy":"frame-ancestors 'self' teams.microsoft.com *.teams.microsoft.com *.skype.com *.teams.microsoft.us local.teams.office.com *.powerapps.com *.yammer.com *.officeapps.live.com *.office.com *.stream.azure-test.net *.microsoftstream.com *.dynamics.com;","MicrosoftSharePointTeamServices":"16.0.0.21820","X-Content-Type-Options":"nosniff","X-MS-InvokeApp":"1; RequireReadOnly","Timing-Allow-Origin":"*","x-ms-apihub-cached-response":"true","Cache-Control":"max-age=0, private","Date":"Fri, 05 Nov 2021 11:45:12 GMT","P3P":"CP=\"ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI\"","X-AspNet-Version":"4.0.30319","X-Powered-By":"ASP.NET","Content-Length":"168","Content-Type":"application/json","Expires":"Thu, 21 Oct 2021 11:45:13 GMT","Last-Modified":"Fri, 05 Nov 2021 11:45:13 GMT"},"body":{"status":404,"message":"File not found\r\nclientRequestId: 8bc4f87b-d9d4-4122-8122-baf2a61cf2c3\r\nserviceRequestId: 8bc4f87b-d9d4-4122-8122-baf2a61cf2c3"}}

 

The successful copy:

ThomasDK_1-1636113948886.png

In Sharepoint:

https://targetdomain.sharepoint.com/sites/NT120/Delte%20dokumenter/Forms/AllItems.aspx?id=%2Fsites%2...

ThomasDK_2-1636113999885.png

 

The failed copy:

ThomasDK_3-1636114141258.png

 

 

In Sharepoint:

https://targetdomain.sharepoint.com/sites/NT120/Delte%20dokumenter/Forms/AllItems.aspx?id=%2Fsites%2...

ThomasDK_4-1636114178347.png

NB: It makes no difference if I say yes/no to "Include Nested Items". What I would like to do here is to exclude just the Email folder, not other potential folders. Anyway, that is a minor thing..  the error is my real issue.

 

I hope one of you out there can tell me if this is a Power Automate error, or if I have done something wrong.

Cheers,

Thomas

 

 

5 REPLIES 5
v-chenzhi
Community Support
Community Support

Hi @ThomasDK,

 

Do you mean you have an error with Copy File?

I have a test on my side according to your situation.

Flow will report the message ‘file not found’ If there is a folder is empty in the directory,  but the Copy File still work.

Please check if there is a folder in this directory is empty.

vchenzhi_0-1636440427324.png

 

 

Best Regards,

Zhi Chen

Hi @v-chenzhi 

 

Thanks for the reply. Yes, there is a problem with the last of the two "Get File" that I use. I have checked if an empty folder is the problem, but the Email folder contains this test file:

ThomasDK_0-1636442703458.png

Best Regards,

Thomas

When I do the same as the first "Get File" (mentioned above) by adding "Emails" to the "Limit entries to folder" the error is gone (Screenshot #1). There is files in the folder "C02 Aftale" as can be seen in screenshot #2 below, so the error cannot be caused by the lack of files in the directory I specify.

 

Screenshot #1:

ThomasDK_0-1636701541152.png

Screenhot #2:

ThomasDK_1-1636701769396.png

 

v-chenzhi
Community Support
Community Support

Hi @ThomasDK ,

 

Sorry, I am pointing in the wrong direction. The SharePoint library has a hidden folder called "Forms" in which templates and system forms are stored.

You can see it when you manually select the path. The form is empty by default. I think this is the reason why Copy File reports an error.

vchenzhi_0-1636710348478.png

 

vchenzhi_1-1636710348481.png

 

So I suggest you use Create file.

vchenzhi_2-1636710348487.png

 

vchenzhi_3-1636710348488.png

 

 

 

Best Regards,

Zhi Chen

Hi @v-chenzhi 

 

Thanks for the reply and I'm sorry I haven't replyed earlier. This part of the soluton has been put on hold, but it will be implemented later, and I will test your porposal. Thanks again 🙂

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

Carousel_PP_768x460_Wave2 (1).png

2022 Release Wave 2 Plan

Power Platform release plan for the 2022 release wave 2 describes all new features releasing from October 2022 through March 2023.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (3,087)