cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lucalerch
Frequent Visitor

Filesystem Gateway - Create Folder

Hi, I want to create a Folder on a local Filesystem on a Windows Server 2016 using a On Premises Data Gateway. I can't find an Option to create a Folder. Is there a Way to create a Folder?

 

Thanks!

Luca

1 ACCEPTED SOLUTION

Accepted Solutions
lucalerch
Frequent Visitor

Statement of Microsoft:

 

Doing some review on the concerns raised so, it has been confirmed by the development team that the experience you are having with creating a new folder, is a known issue. The solution provided by my colleague was provided by the development team as a short-term fix for the experience you have pending when this will be resolved.

 

Currently, the team is actively working on this issue, however, they have not provided a timeline as to when this issue will be resolved hence our inability to provide you with the information regarding a possible fix timeline.

 

The solution they have provided is as follows :

Kindly ask your AD Admin to set this AD user language to English and re-sync to AAD and make sure the data gateway’s exception does not show with the local language instead of English. Please note that changing the local PC language will not resolve this issue.

View solution in original post

15 REPLIES 15
Paulie78
Super User
Super User

It's been a while since I used it, but I do not believe there is. But if you create a file in a directory that does not yet exists, I think it automatically creates it. 

Thanks for your Reply. Unfortunately when I want to create a File in a Folder, which doesn't exists, there is an error...

Paulie78
Super User
Super User

I just tried it and it worked fine for me:

2021-04-14_10-33-21.png

It created the folder and then the file. What error did you get?

lucalerch_0-1618393449825.png

This is the Action. When i set the Folderpath to \\srvfile01\Daten\01_Kunden\A it works fine. 

 I get the following error message:

{
  "status"400,
  "message""Die angeforderte Aktion konnte nicht ausgeführt werden. Überprüfen Sie Ihre Anforderungsparameter, um sicherzustellen, dass der Pfad \"\\\\srvfile01\\Daten\\01_Kunden\\A\\Test/test.txt\" in Ihrem Dateisystem vorhanden ist.\r\nclientRequestId: 261107d1-6896-4714-a841-8824e4f15010",
  "error": {
    "message""Die angeforderte Aktion konnte nicht ausgeführt werden. Überprüfen Sie Ihre Anforderungsparameter, um sicherzustellen, dass der Pfad \"\\\\srvfile01\\Daten\\01_Kunden\\A\\Test/test.txt\" in Ihrem Dateisystem vorhanden ist."
  },
  "source""filesystem-we.azconn-we-01.p.azurewebsites.net"
}
 
 
Hope you find my mistake 🙂
 
Thanks! 
Luca
Paulie78
Super User
Super User

Seems like it should work. Does the user that the connection is running under permission to create files in that folder?

The User has Access to the Folder and can create Folders. 

Mark-Shenouda
Microsoft
Microsoft

@lucalerch 
Can you validate the path is correct ... In the screenshot you added the full path , but it should be relative to the root path defined in the file system connection. 

Thanks for your Reply. The path is correct.

 

This isn't working:

lucalerch_0-1618408812702.png

 

But this is Working:

lucalerch_1-1618408852278.png

 

 

Mark-Shenouda
Microsoft
Microsoft

@lucalerch 
I tried on my flow and it seems to be able to create folders 
Can you check that the folder is shared with the user and that he has full control 
Just for testing try creating a test folder and share it with everyone with full control and see if you still get the error

Mark-Shenouda_0-1618472163476.png

 

@Mark-Shenouda

 

I created a new Folder "test" Everyone has Full Control. Unfortunately it doesn't work.

 

Error Message:

Die angeforderte Aktion konnte nicht ausgeführt werden. Überprüfen Sie Ihre Anforderungsparameter, um sicherzustellen, dass der Pfad "C:\Test\TestFolder/test.txt" in Ihrem Dateisystem vorhanden ist.
clientRequestId: 742c499a-2ae7-499f-94d2-e603d1ac4f24

 

 

@Mark-Shenouda 

I installed a Gateway on my Notebook and tested it. There ist the same problem: "Path not found"

lucalerch
Frequent Visitor

Statement of Microsoft:

 

Doing some review on the concerns raised so, it has been confirmed by the development team that the experience you are having with creating a new folder, is a known issue. The solution provided by my colleague was provided by the development team as a short-term fix for the experience you have pending when this will be resolved.

 

Currently, the team is actively working on this issue, however, they have not provided a timeline as to when this issue will be resolved hence our inability to provide you with the information regarding a possible fix timeline.

 

The solution they have provided is as follows :

Kindly ask your AD Admin to set this AD user language to English and re-sync to AAD and make sure the data gateway’s exception does not show with the local language instead of English. Please note that changing the local PC language will not resolve this issue.

sdbr
Frequent Visitor

I can confirm the problem. I have changed AD user language to English but the problem is not fixed.
The flow fails on Windows 10 but seems to be working fine with Windows server 2012 R2. 

 

Config:
ConfigConfig

Error:

ErrorError

Christoph188811
New Member

This is still unresolved?
I swapped the languge to English but doesnt help.

lucalerch
Frequent Visitor

Unfortunately, the issue is still unresolved.

 

For me it also didn't worked with changing Language to english. I don't think Microsoft will solve this issue -> They want you to use SharePoint.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (3,284)