cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Keesl
Frequent Visitor

Filter query stopped working

Hi all,

 

A flow I have been using for some time now and has ben working fine is suddenly no longer working properly. Part of the flow uses the get files function and uses a simple query to filter files through a column I added to the document library. The filter is simply as follows:

 

Keesl_0-1608635180949.png

 

This was working fine but now it no longer picks up any files, even though they are in the library with correct CropReportID tags. The column is a single line of text. Do I need to add quotes around my ID field?

1 ACCEPTED SOLUTION

Accepted Solutions
Keesl
Frequent Visitor

Hi,

 

Thanks @tom_riha and @ChristianAbata  for your suggestions. I already tried those and it made no difference. I did look at other possible issues and left it for a day or so. When I got back to it I realised that I had reached the magic 5000 file limit. I added the following to the Get files action, Order by Modified desc and Top count 500 as below:

 

Keesl_0-1609238154176.png

 

This goes through the latest 500 files only, rather than 5000.

 

Thanks for your replies.

View solution in original post

3 REPLIES 3
ChristianAbata
Super User II
Super User II

Hi @Keesl  please try adding quotes at the beginig of ID propertie and at the edn like this ' ID ' 



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
tom_riha
Super User II
Super User II

Hello @Keesl ,

yes, you need to add quotes around the ID dynamic content, just quotes, no spaces.



[ If I have answered your question, please Accept the post as a solution. ]
[ If you like my response, please give it a Thumbs Up. ]

[ I also blog about Power Automate solutions even for non-IT people. ]
Keesl
Frequent Visitor

Hi,

 

Thanks @tom_riha and @ChristianAbata  for your suggestions. I already tried those and it made no difference. I did look at other possible issues and left it for a day or so. When I got back to it I realised that I had reached the magic 5000 file limit. I added the following to the Get files action, Order by Modified desc and Top count 500 as below:

 

Keesl_0-1609238154176.png

 

This goes through the latest 500 files only, rather than 5000.

 

Thanks for your replies.

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (81,427)