cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Shegs
Advocate II
Advocate II

Flow Case Switch Failing

odd that it's failing, I have created case switch that works in other flows... am I missing something?

 

For me to troubleshoot I have super simplified the case and actions to just a notify.

I get rows from SQL (filtering to 1 row for this troubleshoot)

I am switching case based on a location field (in this case the number 10)

if the switch is gone, everything else has been working... but that doesn't help when there may be hundreds of rows of data.2018-06-13_15-16-40.jpg

 

1 ACCEPTED SOLUTION

Accepted Solutions

I found the issue.

the switch will only work with columns of datatype INT....

not sure exactly why it was failing, but I altered the view to change the value I was switching on to INT from varchar and it worked fine...2018-06-14_8-09-54.jpg

View solution in original post

9 REPLIES 9

It isn't the switch that is failing as the notification is failing. Ohterwise the notifdication step wouldn't run. Can you show the notification action details in edit mode.

Yeah, it looks like it's going through the switch, but I've removed the switch and it's worked... I'll attempt again real quick and send the results

 

here it is currently

2018-06-14_7-12-52.jpg

all I did here was move the notification out of the switch branch and it worked fine.

while the exact same notification (this time in location 15) failed while inside the switch branch

2018-06-14_7-16-46.jpg

Notification.PNG 

I just reproduced this problem. i would add this to the I found a bug section

 

In the meanwhile I would use send an Email actions

I'll move it over to a bug thread, but this notification wasn't the only thing failing inside the switch.

the notifications were just used for troubleshooting.

 

what baffles me the most is I have a working switch I also made yesterday in a different flow.

 

2018-06-14_7-44-50.jpg2018-06-14_7-46-20.jpg

That doiesn't make sense. I'm sure I have sent emails inside a switch before.

 

Can you try exporting the flow and then importing it as a new flow. That way the connections should be reset.,

it doesn't even have to be emails

2018-06-14_7-57-54.jpg2018-06-14_7-58-32.jpg

I found the issue.

the switch will only work with columns of datatype INT....

not sure exactly why it was failing, but I altered the view to change the value I was switching on to INT from varchar and it worked fine...2018-06-14_8-09-54.jpg

I've been having issues with this all day. So glad I found this! Thank you!

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (1,695)