cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MoniqueLMillan
Regular Visitor

Flow Condition not working properly

The flow is canceling at the condition. However, just an hour ago there was not issue. 

Ex. 1 the build-out

MoniqueLMillan_0-1602624790437.png

Ex. 2 This is the first attempt with success

MoniqueLMillan_1-1602624876022.png

Ex 3. The same flow canceled

MoniqueLMillan_2-1602624946517.png

What am I missing? 

1 ACCEPTED SOLUTION

Accepted Solutions

Solution. All I did was as "Compose" above the condition. 

The selected input was the same as what I used in the Condition. 

MoniqueLMillan_0-1602710433144.png

Upon testing it all flowed without a loop and as I built it. Thank you for your help @abm 

View solution in original post

3 REPLIES 3
abm
Super User
Super User

Hi @MoniqueLMillan 

 

This is by design. Yes I agree this is a bit misleading but here is the explanation.

 

The conditions set in the condition are not met when Flow executes the action in the IF NO branch. The value of Status set in the "Terminate action" is Cancelled, so Run history shows that the Condition is Cancelled.

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

So I removed Terminate and the flow successfully ran, but the expectation was not met. What triggers the flow is when an item is modified. My action is based on the fields "CR Analyst Dispo" or "Builder Dispo". However, in the condition when I select "is equal to" and the fields are set to that, the flow does not run correctly. The condition tells me input is false. See screenshots below for examples. 

 

List (Please note that the action/condition is impacted only by the two fields "CR Analyst Dispo" or "Builder Dispo" - NOt an Issue)

MoniqueLMillan_0-1602697697795.png

Ex. 1 (condition is set to "equal to")

Screenshot 2020-10-14 105129.jpg

Here is the Test Run - Please notice how the condition input was "False" which is not the case, the fields match the expected condition and the condition input should have been true based on the fields and the set condition.

Screenshot 2020-10-14 110005.jpg

 

Solution. All I did was as "Compose" above the condition. 

The selected input was the same as what I used in the Condition. 

MoniqueLMillan_0-1602710433144.png

Upon testing it all flowed without a loop and as I built it. Thank you for your help @abm 

Helpful resources

Announcements
Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (5,226)