cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Martafang
Level: Power Up

Flow Condition not working

I built a simple flow. The purpose is when a file is added to OneDrive, copy it automatically to Sharepoint based on the file name. When I added a file (file name contains Test) to OneDrive, the flow ran successfully but the file didn't copy to Sharepoint. Please somebody tell me what I did wrong. Thanks a lot!

 

Flow.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User
Dual Super User

Re: Flow Condition not working

Hey @Martafang 

 

In the one drive connector, for a When a new file is created trigger, the trigger is set off as soon as the file is created and teh file name attribute gets the internal unique name of the file that is generated in OneDrive. You need to add the get file metadata to get the display name of the file and then use that in the condition. 

rr32.PNG

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

5 REPLIES 5
Gristy
Level 10

Re: Flow Condition not working

look at your flowrun and compare what the trigger is inputting into the condition with what you have set as the condition.

 

If it is not hitting the yes branch, then the condition must not be correct.

Dual Super User
Dual Super User

Re: Flow Condition not working

Hey @Martafang 

 

In the one drive connector, for a When a new file is created trigger, the trigger is set off as soon as the file is created and teh file name attribute gets the internal unique name of the file that is generated in OneDrive. You need to add the get file metadata to get the display name of the file and then use that in the condition. 

rr32.PNG

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Community Support Team
Community Support Team

Re: Flow Condition not working

Hi @Martafang ,

 

Please take a try with @yashag2255 's solution and let me know if your problem could be solved.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Martafang
Level: Power Up

Re: Flow Condition not working

Thanks, yashag2255. Your solution worked!

Martafang
Level: Power Up

Re: Flow Condition not working

It turned out that I needed "Get file matadata" before Condition. See yashag2255's solution.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (7,118)