cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
thegnic
Frequent Visitor

Flow Error

Hi, hope someone can help...

 

I'm building a flow on a SharePoint list. Each item on the list as an 'order type' & 'job type'. I want to set it to email certain people if a new item appears with specific order and job type. I've managed to setup the flow to successfully email people when a specific order type is selected however when trying to delve deeper and split the order type into job type I'm getting the error below:

 

 
1 ACCEPTED SOLUTION

Accepted Solutions
askondo
Microsoft
Microsoft

What is set for "Select an output from previous steps" in the flow "Apply to each2"? From what I see in the error, it looks like a string item has been set there. An Array entry should be specified there.

 

 

View solution in original post

7 REPLIES 7
thegnic
Frequent Visitor

For some reason it didn't put the rest of my message in. Here it is:

 

flow error.png

 

 
thegnic
Frequent Visitor

And again, not sure what is going on here:

 

I've set it to use a switch on the order type to email specific users - this works fine. I've then tried to split one of the order types down into job types, using a switch again and I get that error.

 

Any advise greatly appreciated.

Thanks

Gary

 
askondo
Microsoft
Microsoft

What is set for "Select an output from previous steps" in the flow "Apply to each2"? From what I see in the error, it looks like a string item has been set there. An Array entry should be specified there.

 

 

View solution in original post

thegnic
Frequent Visitor

Hi Askondo,

 

Thanks for the reply. Here are a couple of screenshots. The 2nd screenshot is the switch that i've got on the 1st screenshot - hope that makes sense:

 

1.png2.png

 

 

 

 

 

 

Cheers

Gary

hi @thegnic  the error is because you are using apply to each that means that you need an array value, (an array in a group of responses). So if you give a string like 1 response this is not an array, thats why you are getting that error.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi, think i have sorted it - looks like I had an extra step in there that wasn't needed. Here is what works now:

 

3.png

 

Thanks all.


Gary

excellent @thegnic  please consider to mark an answer as solution and like it, if could help you to solved what you need



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (77,386)