cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
samstarzy
Advocate IV
Advocate IV

Flow Fail: Update "Person or Group" Type Metadata in Sharepoint Document Library From Sharepoin List

Hello all,

I am building a flow that takes an attachment (and metadata) that a user submits to a Sharepoint list and copies it to a specified document library.

 

I was able to successfully run this flow until I added a data collumn to capture the person that submitted the list item and attachment to trigger the flow. See below.

Capture.PNG

 

I then added this metadata to my document library and the flow began failing, both when trying to update the data, and when leaving it blank. See below.

 Capture1.PNG

 

 

 

Here is the flow when it is set to leave the "Submitted by claims" field blank.

 

Capture2.PNGThe metadata should not copy over here.

 Here is the error output when the flow is instructed to leave the data blank, as seen above.


Capture4.PNGHighlighted error message included below

 

Body

{
  "message""User value is invalid.\r\nclientRequestId: e560c883-3179-4a0e-b860-f3cba7b69a56\r\nserviceRequestId: 0274709e-0082-0000-0a60-c458b70cd648",
  "status"400,
  "source""https://ndepanaconda.sharepoint.com/sites/anacondapublicrecords/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

 

And here is the flow when the "Submitted by Claims" data is set to be taken from "When an item is Created" dynamic content.

 

Capture3.PNG"Submitted by Claims" taken from "When an Item is Created" Dynamic Content

 And here is that flow failing.

Capture5.PNGError message is the same as before. See below.

 

Body
{
  "status"400,
  "message""User value is invalid.\r\nclientRequestId: a873746a-5ca5-4f4b-992a-f6270abd3c1e\r\nserviceRequestId: 0472709e-3046-0000-0a60-c31393e07f91",
  "source""https://ndepanaconda.sharepoint.com/sites/anacondapublicrecords/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

I am really confused as why this is failing. Any help would be greatly appreciated. Please let me know if there is anything I can do to clarify what is going on here.

Thank you,
Sam

7 REPLIES 7
ScottShearer
Super User III
Super User III

I am having similar issues - I suspect that this may be a bug.

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Is there a way to report this as a bug then?

If you believe you found a bug, report it here

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Anonymous
Not applicable

Hi,

In my scenario,

I'm having a people picker with multi select users option and by using send HTTP request to sharepoint i was able to get User details into PowerApps,

But When i try to use the same method and Get details of Another column details which is just a Singleline Text column. Its giving me Error on flow: The field or property 'Description' does not exist 

 

Any ideas would help.

Thanks

JS1
Frequent Visitor

Did you ever get a resolution to this?

Having similar issue as well, would be great to find a resolution or whether this is feasible at all.

Dodge
Advocate I
Advocate I

Same problem as the others, any idea on when this bug will be addressed?

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (43,559)