cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
samstarzy
Level: Powered On

Flow Fail: Update "Person or Group" Type Metadata on Document Library From List

Hello all,

I am building a flow that takes an attachment (and metadata) that a user submits to a Sharepoint list and copies it to a specified document library.

 

I was able to successfully run this flow until I added a data collumn to capture the person that submitted the list item and attachment to trigger the flow. See below.

Capture.PNG

 

I then added this metadata to my document library and the flow began failing, both when trying to update the data, and when leaving it blank. See below.

 Capture1.PNG

 

 

 

Here is the flow when it is set to leave the "Submitted by claims" field blank.

 

Capture2.PNGThe metadata should not copy over here.

 Here is the error output when the flow is instructed to leave the data blank, as seen above.


Capture4.PNGHighlighted error message included belowBody

{
  "message""User value is invalid.\r\nclientRequestId: e560c883-3179-4a0e-b860-f3cba7b69a56\r\nserviceRequestId: 0274709e-0082-0000-0a60-c458b70cd648",
  "status"400,
  "source""https://ndepanaconda.sharepoint.com/sites/anacondapublicrecords/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

 

And here is the flow when the "Submitted by Claims" data is set to be taken from "When an item is Created" dynamic content.

 

Capture3.PNG"Submitted by Claims" taken from "When an Item is Created" Dynamic Content

 And here is that flow failing.

Capture5.PNGError message is the same as before. See below.

 

Body
{
  "status"400,
  "message""User value is invalid.\r\nclientRequestId: a873746a-5ca5-4f4b-992a-f6270abd3c1e\r\nserviceRequestId: 0472709e-3046-0000-0a60-c31393e07f91",
  "source""https://ndepanaconda.sharepoint.com/sites/anacondapublicrecords/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

I am really confused as why this is failing. Any help would be greatly appreciated. Please let me know if there is anything I can do to clarify what is going on here.

Thank you,
Sam

Helpful resources

Announcements
firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

thirdImage

New Flow Community Board!

Check out the new Microsoft Flow Community Blog Topic Suggestion board!

fourthImage

Australia Summit

Travel to Melbourne and network with thousands of peers!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 22 members 4,251 guests
Please welcome our newest community members: