cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JohnBrown
Level: Powered On

Flow Failes to create records but marked as successful run

I have created a flow that creates several thousand records in our instand of Dynamics 365. However I was receiving a 429 error (that I was hitting the Dynamics API to often) and the flow failed a few times as a result. In order to remediate these error, I updated the Retry Policy to below. RetryPolicy.JPG

As a result, I am no longer getting the 429 errors, but records are not being created. It missed 314 out of 6400. All the flows are marked as being successful but clearly they were not. Any ideas on what would cause this? 

 

3 REPLIES 3
v-zhos-msft
Level 10

Re: Flow Failes to create records but marked as successful run

Hi @JohnBrown ,

Could you please share a screenshot of your flow's configuration?

As you said the flow missed 314 out of 6400 records.

I suggest you change the Interval to longer to see the issue if still exist.

Or you can try to create less  records for a test.

 

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

JohnBrown
Level: Powered On

Re: Flow Failes to create records but marked as successful run

@v-zhos-msftIt works with fewer records. The problem that has forced me to use flow is that I need to be able to handle large numbers of records. I was getting a 429 error previously and increased the retry policy time so that the flow no longer threw 429 errors, but completed successfully however it still missed records. Eventually I stopped splitting out the records by turning "Split On" off for the Dynamics trigger "When a Record is Created" and rebuilding the flow appropriately.  This helped the most, now it works about half the time. The other half it either creates too many records or fails to trigger when the record is created within Dynamics. 

 

SpitOffFlow.JPG

v-zhos-msft
Level 10

Re: Flow Failes to create records but marked as successful run

Hi @JohnBrown ,

I suggest you turn on the 'Pagination' in the setting of 'List records'. And set the max

number of items to retrieve.

Then try the flow again to see the issue if still exist.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 356 members 4,890 guests
Please welcome our newest community members: