cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jambo1
Advocate II
Advocate II

Flow Failing due to Template Error

Unable to process template language expressions in action 'Return_all_previous_Approved_submissions' inputs at line '1' and column '2532': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sharepointonline']['connectionId']' cannot be evaluated because property 'shared_sharepointonline' doesn't exist, available properties are 'shared_sharepointonline_2, shared_approvals_2, shared_sendmail_2'. Please see https://aka.ms/logicexpressions for usage details.'.

 

I get this error after editing a flow that is co-owned by a colleague. Rolling back my change just moved the same error on to another update item block. 

 

Both of us had connections to Sharepoint but deleting them and recreating them didnt help. 

 

only when I exported and imported as new did this fix the problem. Does this mean that we need to be very careful if 2 users are editing the same flow?

 

thanks

 

Jambo

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

Hi @Jambo1,

 

I see similar situation with your issue in some similar Threads, as mentioned by Pieter_Veenstra, similar problems occur sometimes when you introduced new connectors to a flow after you have initially saved the flow without using that connector.

The effective solution is the same as you described, which is to export the Flow and then re-import it as a new Flow, and the new Flow will work.

It seems that this does not matter much if there are multiple people editing the same Flow at the same time.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

thanks @v-bacao-msft

 

it does sound like the same problem in that we end up introducing new connections (e.g. we have a Sharepoint connector authorised to user A then User B edits and Sharepoint connector Authorised to B is created)

 

Do youu know if this is something the Dev team are working on to improve?

 

thanks

Jambo

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,522)