cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
master_NK
Frequent Visitor

Flow Get Attachment now failing

Hi.

 

I have 9 Flows that are all the same structure.

 

When new mail arrives > Get email, then Get Attachment and create that in Sharepoint.

All the flows have been working perfectly until Yesterday, Now the all fail at the GET ATTACHMENT action.

 

""error": {
    "code""ErrorInvalidMailboxItemId",
    "message""Item Id doesn't belong to the current mailbox."
  }"
 
Yet the GET email works with the same connector and that is working:
 
 
FLOWFLOW

 

ErrorError

 

 
 
1 ACCEPTED SOLUTION

Accepted Solutions

SO i finally got mine fixed. Was using an account that was only a Exchange online licenses - changed the License to a Basic Business Licenses and redid the connectors and now all is working

View solution in original post

9 REPLIES 9
ChristianAbata
Super User II
Super User II

@master_NK  please check the conection of both actions are the same.

 

conas.PNG



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
alrez
Microsoft
Microsoft

Hi,

 

There seems to be some mismatch between where the email is arriving and where the get attachment action is trying to look. If you are triggering when a mail arrives in a shared mailbox, it might be trying to search your mailbox and isn't looking into the shared one. I would check the connections as per Christian's suggestions.

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

jamikulas
New Member

I have the exact same issue.  Receive email, save attachments to SharePoint, record email in spreadsheet.  Everything worked great until yesterday.  Something had to have changed.

 

Now, my workflow is suspended, and I cannot figure out how to re-enabled it.

DannyBoy2042
Frequent Visitor

 We are having same issue.  These flows worked for 9 months or more and now they are all broken.  I am seeing on the forums we are not the only ones.  Everyone getting "Item Id doesn't belong to the current mailbox".

hi @DannyBoy2042  @master_NK it seems that this is an issue and MS support team its working on it. I try to repply your error an yesterday get the same error but todays works find. Please try deleting your conections and rebuilt the flow.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

SO i finally got mine fixed. Was using an account that was only a Exchange online licenses - changed the License to a Basic Business Licenses and redid the connectors and now all is working

View solution in original post

Where can we see evidence of Microsoft working to resolve this so we'll know when it's fixed? 

I have a support ticket in with them, they gave me a workaround to use MS Graph.  Not ideal but these were production flows and needed to work.  I was told that this is result of them removing some legacy flow triggers (When new mail arrives in a share mailbox).  Unfortunately i had 10 of these and had do a work around for them all using MS Graph. 

My 9 flows were working just fine - and mostly continue to do so, except for the last step in each where I'm using Mark as Read V2 for items within a shared mailbox. Microsoft must have changed how Flows work with shared mailboxes which broke this action. I'm trying Delete V2 next since I really don't need to keep copies of the emails once the flow has uploaded the attachments to SharePoint. Here's hoping!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Kudoed Authors
Users online (2,294)