cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
exnav29
Level: Powered On

Flow Runs, then Fails

Hi,
 I see strange behavior with a flow I created.  It is a simple flow which is triggered when a new item is created in a SharePoint Online list.  The flow retrieves the manager's name and then updates the item, with the manager's name.  It also updates the information in the list for the requestor's department, Job Title and title of the item (concatenates the requetor's name and request type fields).  I am using O365 users for this solution.

 

  The flow will run initially when I test. The log shows that it ran successfully, and I can verify this by looking at the item in the SharePoint list, and it is updated.  If I go back into the flow log  I see that it shows that it ran successfully.  But then there is a second entry saying that it failed.  When looking into the details, it failed at the first step of when an item is created.  With the details of "Resource not found"  It then proceeds to produce a fail message every 15 seconds after that.

 

If I try to do another test by creating a new item, it just fails and does not complete successfully.  Has anyone else seen this behavior?  Is there a workaround for this? As it stands now If I delete the flow and recreate it I get the same experience of the flow running initially and then failing afterwards.

3 REPLIES 3
Microsoft telu
Microsoft

Re: Flow Runs, then Fails

Hi exnav29,

 

Can you share with me the flow id?

When you open the flow, the URL should look like the following

https://flow.microsoft.com/manage/flows/<xxx>

it's a guid.

 

Thanks

Highlighted
exnav29
Level: Powered On

Re: Flow Runs, then Fails

Hi,

The GUID is c902413e-2cdb-473b-9882-662ddb835dde.

Microsoft telu
Microsoft

Re: Flow Runs, then Fails

Hi exnav29,

 

From the symptom, it seems the item you created or want to edit is missing. Is your flow "vacation"? Here is the error:

{
"$schema": "2016-04-01-preview",
"startTime": "2016-07-06T01:54:55.8345332Z",
"endTime": "2016-07-06T01:54:55.9126577Z",
"status": "Failed",
"code": "NotFound",
"tags": {
"flowDisplayName": "Vacation"
},
"resource": {
"subscriptionId": "655be0f1-fb2c-4c5a-9fbf-ff414e1b901b",
"resourceGroupName": "6945C3CA3FAD411C97488CB53D8FCE86-AC3E6784C6AD4C3C8CA7A6BB1F7B6671",
"workflowId": "2f6781eb83fd4cc686c88b6585431605",
"workflowName": "c902413e-2cdb-473b-9882-662ddb835dde",
"runId": "08587338367896332217",
"location": "westus"
},
"correlation": {
"clientTrackingId": "08587338367896332217"
}
}

I created a flow with trigger "when a new item is created in sharepoint" -> action " edit sharepoint", I ran twice and it works for me.

so If you can take a screenshot for your flow, it would provide me more details.  

 

sharepoint.PNG

Thanks,

Teng

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (5,654)